Вопрос по шаблонам для СМS

Тема в разделе "OpenCart", создана пользователем kocapb, 14 июн 2016.

Метки:
  1. kocapb

    kocapb

    Регистрация:
    16 ноя 2015
    Сообщения:
    32
    Симпатии:
    2
    Пол-года использую смс prestashop 1.6 для своего магазина.
    Воспользовался стандартным шаблоном, многое поменял в нем, меняя код.
    Теперь столкнулся с проблемой, когда не могу установить ни один шаблон. Пробовал штук 10 разных - все отображаются либо криво, либо без картинок(даже после перегенерации картинок). Где-то сбиваются ссылки на страницы, не работают модули и прочие проблемы. Толком не получилось настроить никакой шаблон, кроме дефолтного.

    В связи с некоторыми другим ограничениями и глюками престы, хочу перейти на Opencart.
    И по этому задаю резонный вопрос - в опенкарте такой-же гемор с шаблонами?
    Если да, то придется тогда на чистый сайт с демо-данными ставить понравившийся шаблон и менять его под свои нужды, при этом забыт о других шаблонах.
     
  2. oltreyn

    oltreyn

    Регистрация:
    7 фев 2014
    Сообщения:
    82
    Симпатии:
    13
    Я бы даже сказал более чемп смело. Главное смотреть под которую версию движка был написан шаблон.
    Но, если шаблон популярный, то он адаптирован под любую из версий
    А для того, чтобы менять что-то в шаблоне нужно редактировать только файлы шаблона. На работу самого движка это никак не повлияет. поэтому в будущем Вы спокойно сможете использовать новые шаблоны на своем проекте.
     
    mr.zefer нравится это.
  3. Dotrox

    Dotrox Команда форума

    Регистрация:
    27 ноя 2012
    Сообщения:
    2.139
    Симпатии:
    817
    Совместимость с движком никак не гарантирует совместимость с модулями. В силу наличия в ОК идиотских модификаторов всегда есть шанс нарваться на несовместимость конкретного шаблона с конкретным модулем.
     
  4. oltreyn

    oltreyn

    Регистрация:
    7 фев 2014
    Сообщения:
    82
    Симпатии:
    13
    Да, но вопрос был задан о другом.
     
  5. Dotrox

    Dotrox Команда форума

    Регистрация:
    27 ноя 2012
    Сообщения:
    2.139
    Симпатии:
    817
    Именно об этом:
    В ОК такое тоже возможно. Есть просто проблемные шаблоны (при этом очень популярные в силу кучи свистелок), но в целом принцип таков - чем дальше шаблон от дефолтного, тем больше с ним будет проблем. И речь идёт не только и не столько о внешнем виде, сколько о том, что под капотом.
    И в плане настроек: есть шаблоны, у которых админка сложнее всей остальной админки ОК в целом.


    Кстати, вот это:
    Для двойки это уже совсем далеко от действительности. Если в 1.5 можно было ещё прямо в шаблоне какую-то информацию получать (хотя это и неправильно с точки зрения MVC), то в двойке всё надо подготавливать в контроллере (который не часть шаблона и будет использоваться с любым). Если от предыдущего шаблона в контроллере просто осталось что-то лишнее - это ещё не страшно, но под старый шаблон, например, мог быть изменён формат вывода какой-то информации, а это уже вызовет ошибки с новым шаблоном.
    Ну, а в добавок: новый шаблон может тянуть с собой модификаторы, которые что-то подгоняют для него в контроллере, но в контроллере уже вносились правки, модификаторы не зацепятся и опять ошибки - такое встречается довольно часто.

    А вёрстку и в PS можно поменять не затрагивая ничего за пределами шаблона.
    На самом деле, PS как раз гибче в плане доработок: он позволяет вносить правки в код не затрагивая оригинальные файлы - любой класс можно переопределить (и положить файл в специальную директорию).
     
    mr.zefer нравится это.
  6. Mrakaz

    Mrakaz

    Регистрация:
    24 дек 2016
    Сообщения:
    11
    Симпатии:
    3
    kocapb, По большей части это касается ломанных шаблонов. А это везде, не зависимо от движка )
    Сам недавно столкнулся с ОС, ocStore, если точнее. Вообще-то понравился, хотя после joomla и wp было непривычно, конечно.
    Из шаблонов, которые понравились мне (один в итоге купил, не пожадничал), могу посоветовать:
    Luxury
    Revolution
     
  7. Dotrox

    Dotrox Команда форума

    Регистрация:
    27 ноя 2012
    Сообщения:
    2.139
    Симпатии:
    817
    Ломаные - это отдельная история (и не только шаблоны). Если что-то декодировали из-под ИонКуба, то в процентов в 90 случаев будут хоть какие-то заметные глюки (а в коде - очень смешные моменты).

    Но в случае ОК из-за особенностей работы модификаторов глюки могут быть и на не ломанном. Случаи, когда какой-то отдельный модификатор не применяется из-за несовпадений в искомом коде встречаются довольно часто. И потом получается, что всё, вроде, и работает, но где-то что-то не срабатывает.