[Решено] Глюки не понятно чего.

Тема в разделе "OpenCart", создана пользователем Ping, 9 июл 2013.

  1. Ping

    Ping PingWin always win Команда форума

    Регистрация:
    29 окт 2012
    Сообщения:
    443
    Симпатии:
    301
    описываю ситуацию, опенкарт 1.5.4.1 максистор - был взлом магазина, добавились какие то ссылки левые, я их по удалял Теперь сеошник обратил внимание что код гугл аналитикса не работает, я глянул, а там куча левых слешей появилось причем только рядом с кавычками (одинарные или двойные). Причем кол-во слешей увеличивается после сохранения.

    Кто то сталкивался с подобным ?
     
  2. Serkist

    Serkist

    Регистрация:
    8 фев 2013
    Сообщения:
    350
    Симпатии:
    72
    у меня такая ситуация была с движком webassyst shop script при сохранении дизайна, только взлома не было, проблему удалось решить ручным прописыванием в коде файла нужного куска.
    т.е. как вариант тупо в файле header.tpl прописать код гугл аналитикс, а из админки удалить.
    Буду тоже рад другим вариантам лечения проблемы.
    magic quotes в htaccess отключал, не помогало.
     
  3. Bnopen

    Bnopen Команда форума

    Регистрация:
    3 мар 2013
    Сообщения:
    1.155
    Симпатии:
    514
    Ping, а вы ставили php_flag magic_quotes_gpc Off в корне .htaccess? (а после этого в настройках опять вставить код аналитикса).
    Вам помогло отключение magic_quotes_gpc?
     
  4. Ping

    Ping PingWin always win Команда форума

    Регистрация:
    29 окт 2012
    Сообщения:
    443
    Симпатии:
    301
    Закомментирован

    Я через БД поменял код и сейчас все в порядке. Но это же не выход лезть в БД что бы поменять что то
     
  5. Bnopen

    Bnopen Команда форума

    Регистрация:
    3 мар 2013
    Сообщения:
    1.155
    Симпатии:
    514
    Ping, так нужно наоборот - раскомментировать. У меня было такое же с максисторе - это как раз и помогло.
     
  6. Ping

    Ping PingWin always win Команда форума

    Регистрация:
    29 окт 2012
    Сообщения:
    443
    Симпатии:
    301
    Не помогло, раскоментировал, а потом еще и включил. Все равно после сохранения настроек слеши появляются.
     
  7. Volsky

    Volsky

    Регистрация:
    22 ноя 2012
    Сообщения:
    192
    Симпатии:
    10
    Возможно проблемы вашего хостера т.к. учитывая, то что вы не учли проблемы в дальнейшем рекомендую делать дампы баз и движка. А вообще уберите доступ к основным конфиг файлам вашего сайта.
     
  8. Ping

    Ping PingWin always win Команда форума

    Регистрация:
    29 окт 2012
    Сообщения:
    443
    Симпатии:
    301
    Спасибо, убрал все.
    Бекапы есть, просто инфу надо добавлять заново.
     
  9. Ping

    Ping PingWin always win Команда форума

    Регистрация:
    29 окт 2012
    Сообщения:
    443
    Симпатии:
    301
    Проблема решилась чисткой файлов от вредоносного кода и "форматированием" аккаунта у хостера.