Какую версию Php использовать?

Тема в разделе "PrestaShop", создана пользователем Serij_85, 12 фев 2016.

  1. Serij_85

    Serij_85

    Регистрация:
    9 янв 2016
    Сообщения:
    87
    Симпатии:
    3
    И в чём разница?
    У меня стояла версия 5.3, а вчера залез в Расширенные настройки - Производительность и там написано, что рекомендуют поменять версию php на 5.4 или выше, а то скоро перестанет действовать поддержка версии 5.3. Или что-то подобное.

    Версия Prestashop 1.6.1.3
     
    Lasted edited by : 12 фев 2016
  2. $iD

    $iD Команда форума

    Регистрация:
    13 мар 2012
    Сообщения:
    3.350
    Симпатии:
    1.378
    поддержки 5.3 уже давно нет, как и 5.4 кстати.
    про отличия можно почитать на php.net.

    а я рекомендую использовать последнюю стабильную - 5.6 (есть 7 версия, но думаю преста не будет на ней работать)
     
    Serij_85 нравится это.
  3. Serij_85

    Serij_85

    Регистрация:
    9 янв 2016
    Сообщения:
    87
    Симпатии:
    3
    Ошибся, да. Специально поменял версию php на 5.3. Вот что выдаёт Преста:
    "У вас установлен РНР версии 5.3.28. Скоро минимальной поддерживаемой PrestaShop версией будет РНР 5.4. Для нормальной рабты в будущем рекомендуем обновить ваш РНР до этой версии сейчас!".
     
  4. $iD

    $iD Команда форума

    Регистрация:
    13 мар 2012
    Сообщения:
    3.350
    Симпатии:
    1.378
    я говорил про поддержку языка php (разработчики уже давно не фиксят и не отслеживают баги в php < 5.4)

    т.е. используя версии ниже 5.5 вы сами себя подвергаете риску быть взломанным через баги в пхп
     
    Serij_85 нравится это.