Kredov long

Модуль ГАЛЕРЕЯ не сохраняет новые альбомы

Тема в разделе "OpenCart", создана пользователем Yu_, 16 янв 2015.

  1. Yu_

    Yu_

    Регистрация:
    6 авг 2013
    Сообщения:
    3
    Симпатии:
    0
    Всем привет.

    Версия магазина: opencart 1.5.4
    Сайт локальный на OpenServer
    Начал изучать OpenCart и PHP. Выполнять разные тестовые примеры, создавать подобие сайтов и т.д.

    Но сталкнулся с не понятной проблемой:

    Когда создаю новый Альбом в модуле Галерея, заполняю все поля, прикрепляю фотки, нажимю сохранить, страница начинает перезагружаться и замирает (вот что в адресной строке:

    devhome.lc/admin/index.php?route=catalog/photo/insert&token=23120a1d8e1c92ab9d666eefe2801635). Если проверить галерею, то видно, что ничего не сохранилось и не создалось. Причем раньше всё работало хорошо. Установил галерею, создал 4 альбома с фотками и перешел к другим модулям для изучения, а сейчас решил добавить еще картинок, но не получатеся.
    Заметил, что в логе ошибок появляются записи такого вида:

    <code>

    2015-01-15 23:32:02 - PHP Notice: Undefined variable: entry_quantity in /home/www/devhome.lc/docs/admin/view/template/catalog/photo_form.tpl on line 704
    2015-01-15 23:32:02 - PHP Notice: Undefined variable: entry_price in /home/www/devhome.lc/docs/admin/view/template/catalog/photo_form.tpl on line 706
    2015-01-15 23:32:02 - PHP Notice: Undefined variable: discount_row in /home/www/devhome.lc/docs/admin/view/template/catalog/photo_form.tpl on line 783
    2015-01-15 23:32:02 - PHP Notice: Undefined variable: special_row in /home/www/devhome.lc/docs/admin/view/template/catalog/photo_form.tpl on line 810
    2015-01-15 23:32:26 - PHP Notice: Undefined index: link in /home/www/devhome.lc/docs/admin/model/catalog/photo.php on line 52
    2015-01-15 23:32:26 - PHP Notice: Error: Unknown column 'link' in 'field list'<br />Error No: 1054<br />INSERT INTO photo_description SET photo_id = '135', language_id = '1', link = '', meta_keyword = '', meta_description = '', description = '' in /home/www/devhome.lc/docs/system/database/mysql.php on line 49
    2015-01-15 23:34:02 - PHP Notice: Undefined variable: entry_quantity in /home/www/devhome.lc/docs/admin/view/template/catalog/photo_form.tpl on line 704
    2015-01-15 23:34:02 - PHP Notice: Undefined variable: entry_price in /home/www/devhome.lc/docs/admin/view/template/catalog/photo_form.tpl on line 706
    2015-01-15 23:34:02 - PHP Notice: Undefined variable: discount_row in /home/www/devhome.lc/docs/admin/view/template/catalog/photo_form.tpl on line 783
    2015-01-15 23:34:02 - PHP Notice: Undefined variable: special_row in /home/www/devhome.lc/docs/admin/view/template/catalog/photo_form.tpl on line 810


    </code>



    Проверял файлы указанные в ошибках, вроед все также, как и в ранее сохраненных. Я перед тем как поменять что-нибудь, создаю копию, чтобы можно было вернуть если что-то не так.

    В чем может быть проблем?
     
  2. antonfox

    antonfox

    Регистрация:
    19 янв 2013
    Сообщения:
    77
    Симпатии:
    9
    Нужно начать с названия модуля который используется для галереи
     
  3. Yu_

    Yu_

    Регистрация:
    6 авг 2013
    Сообщения:
    3
    Симпатии:
    0
    А где можно узнать версию модуля? В админке называется "Галерея"
    Сделал скрин модуля в админке: https://cloud.mail.ru/public/659731a60d5b/1.jpg
     
  4. Yu_

    Yu_

    Регистрация:
    6 авг 2013
    Сообщения:
    3
    Симпатии:
    0
    Еще заметил такую вещь:

    В phpmyadmin -- база данных -- выбираю "Таблица: photo" и вижу все альбомы, которые я пытался ранее создать. Если перейти в таблицу "photo_description" то там только старые альбомы, но если создать таблицу с ID не видимого альбома, то в админке появляется нужный альбом, далее вношу изменения, нажимаю сохранить и альбом появляется в галереи.
    Не подскажите, как можно восстановить связь с таблицей "photo_description" ?