[Помогите] Модуль блога сломал сео модуля статей

Тема в разделе "OpenCart", создана пользователем alexsofdev, 20 фев 2013.

  1. alexsofdev

    alexsofdev

    Регистрация:
    13 янв 2013
    Сообщения:
    239
    Симпатии:
    46
    В опенкарте есть штатный модуль статей, который годится исключительно для оформления ссылок вверху\внизу сайт, типа контакты, оплата и доставка. Как только добавил модуль блог - статьи перестали открываться по сео-урлам, которые в них прописаны.

    Кто сталкивался?
     
  2. alexsofdev

    alexsofdev

    Регистрация:
    13 янв 2013
    Сообщения:
    239
    Симпатии:
    46
    Вобщем раскопки показали что проблема в seo_pro.php, причем я совершенно не понимаю как так вышло, но seo_pro рассчитывает на формат записей в базе "тип сущности=айди сущности" и если натыкается на что-то другое, то заканчивается сообщением об ошибке:
    Код:
    Undefined offset: 1 /var/www/*****/seo_pro.php on line 44
    
    На этой строке находится такой вот код:
    Код:
    $this->request->get[$url[0]] = $url[1];
    
    Ну а $url это то, что получается после сплита информации из базы по знаку "=". Например если там написано "information/contact", то я получаю ошибку про строку 44 и меня выкидывает на главну. А если там написано "information_id=48", то я получаю вожделенную страничку контактов.

    Собственно как бы понять че за хрень накидала первый вариант данных в табличку url_alias и можно ли все оттуда тупо гупнуть?
     
  3. personash

    personash

    Регистрация:
    27 окт 2012
    Сообщения:
    285
    Симпатии:
    304
    vqmod_news_reviews_seo_pro.xml есть такой файл ?
     
  4. alexsofdev

    alexsofdev

    Регистрация:
    13 янв 2013
    Сообщения:
    239
    Симпатии:
    46
    нет такого файла. Но зато есть какой-то seo pack pro с кнопкой "сгенерить короткие урлы" и как раз в примерах та хрень, которая была у меня в базе. Видимо это я "нагенерил".