Некорректное отображение сайта в EXPLORER

Тема в разделе "OpenCart", создана пользователем kuklev, 12 окт 2013.

  1. kuklev

    kuklev

    Регистрация:
    31 дек 2012
    Сообщения:
    147
    Симпатии:
    2
    Уважаемые форумчане!

    Подскажите, почему в EXPLORER сайт отображается некорректно?

    Вся верстка летит в принципе, особенно на страницах с товаром:

    http://benkoni.com/shokolad-s-logotipom/shokoladnyj-pazl-na-48-konfet.html
    И еще одна проблема, перепробовал кажется уже все....

    Сделал два вида покупателей: Физические и Юридическое лицо. В самом модуле (в настройках модуля SSIMPLE) он все видит, галочки предлагать выбор типа покупателя проставлены, но при оформлени заказа изменить это невозможно. Даже когда по умолчанию ставлю физическое лицо, все равно устанавливается юридическое лицо.
     
    Последнее редактирование: 12 окт 2013
  2. Вова талибан

    Вова талибан

    Регистрация:
    6 мар 2013
    Сообщения:
    53
    Симпатии:
    19
    в какой версии?
     
    kuklev нравится это.
  3. kuklev

    kuklev

    Регистрация:
    31 дек 2012
    Сообщения:
    147
    Симпатии:
    2
  4. Вова талибан

    Вова талибан

    Регистрация:
    6 мар 2013
    Сообщения:
    53
    Симпатии:
    19
    где-то такое видел, у тебя может быть не закрыта какая-то из директив для отработки стилей только ИЕ
    вообще на сайте там полный хлам в коде, черт ногу сломит
     
  5. kuklev

    kuklev

    Регистрация:
    31 дек 2012
    Сообщения:
    147
    Симпатии:
    2
    <!--[if (gt IE 9)|!(IE)]><!-->

    Это в каком файле искать?
     
  6. Вова талибан

    Вова талибан

    Регистрация:
    6 мар 2013
    Сообщения:
    53
    Симпатии:
    19
  7. kuklev

    kuklev

    Регистрация:
    31 дек 2012
    Сообщения:
    147
    Симпатии:
    2
    Код там следующий:

    <!DOCTYPE html>
    <!--[if lt IE 7 ]> <html lang="en" class="no-js ie6"> <![endif]-->
    <!--[if IE 7 ]> <html lang="en" class="no-js ie7"> <![endif]-->
    <!--[if IE 8 ]> <html lang="en" class="no-js ie8"> <![endif]-->
    <!--[if IE 9 ]> <html lang="en" class="no-js ie9"> <![endif]-->
    <!--[if (gt IE 9)|!(IE)]><!-->
    <html dir="<?php echo $direction; ?>" lang="<?php echo $lang; ?>">
    <!--<![endif]--><head>


    Если честно, вообще ничего в этом не понимаю. Есть ли здесь ошибки?
     
  8. Вова талибан

    Вова талибан

    Регистрация:
    6 мар 2013
    Сообщения:
    53
    Симпатии:
    19
    да код я сам увидел
    прочитай вот что http://htmlbook.ru/samlayout/internet-explorer/uslovnye-kommentarii
    а потом попробуй удалить все, что внутри условных комментариев, касающихся всех версий ИЕ - если проблема исчезнет, то дело в этом, если не исчезнет - то... должна исчезнуть в общем)
     
  9. kuklev

    kuklev

    Регистрация:
    31 дек 2012
    Сообщения:
    147
    Симпатии:
    2
    Прочитал, и них...а не понял, но все равно спасибо. Буду разбираться, так как HTML для меня закрытый мир.
     
  10. kuklev

    kuklev

    Регистрация:
    31 дек 2012
    Сообщения:
    147
    Симпатии:
    2
    А править только здесь
    <!DOCTYPE html>
    <!--[if lt IE 7 ]> <html lang="en" class="no-js ie6"> <![endif]-->
    <!--[if IE 7 ]> <html lang="en" class="no-js ie7"> <![endif]-->
    <!--[if IE 8 ]> <html lang="en" class="no-js ie8"> <![endif]-->
    <!--[if IE 9 ]> <html lang="en" class="no-js ie9"> <![endif]-->
    <!--[if (gt IE 9)|!(IE)]><!-->
    <html dir="<?php echo $direction; ?>" lang="<?php echo $lang; ?>">
    <!--<![endif]--><head>

    Или же править во всем файле?

    При чем у меня возникает стойкое ощущение, что проблема вовсе не в header.tpl а в product.tpl так как все категории все страницы отображаются корректно, летят только страницы с товаром, при чем летят полностью.
     
    Последнее редактирование: 12 окт 2013
  11. sekretenko

    sekretenko

    Регистрация:
    3 окт 2013
    Сообщения:
    38
    Симпатии:
    2
    У тебя не прописан клас стилей для ИЕ10.
     
    kuklev нравится это.
  12. kuklev

    kuklev

    Регистрация:
    31 дек 2012
    Сообщения:
    147
    Симпатии:
    2
    <!--[if (gt IE 10)|!(IE)]><!-->

    Должно быть что то подобное?
     
  13. _KostYAn_

    _KostYAn_

    Регистрация:
    5 сен 2013
    Сообщения:
    41
    Симпатии:
    0
    Проверьте кодировку у product.tpl, должна быть UTF-8 without BOM
    /html/catalog/view/theme/default/template/product
     
  14. kuklev

    kuklev

    Регистрация:
    31 дек 2012
    Сообщения:
    147
    Симпатии:
    2
    Проверьте кодировку у product.tpl, должна быть UTF-8 without BOM
    /html/catalog/view/theme/default/template/product


    Это все перепроверено. Все в правильной кодировке. Помогло дописание стиля для IE10.

    Исходный код (который выдавал ошибку)

    <! DOCTYPE html>
    <!--[if lt IE 7 ]> <html lang="en" class="no-js ie6"> <![endif]-->
    <!--[if IE 7 ]> <html lang="en" class="no-js ie7"> <![endif]-->
    <!--[if IE 8 ]> <html lang="en" class="no-js ie8"> <![endif]-->
    <!--[if IE 9 ]> <html lang="en" class="no-js ie9"> <![endif]-->
    <!--[if (gt IE 9)|!(IE)]><!-->
    <html dir="<?php echo $direction; ?>" lang="<?php echo $lang; ?>">
    <!--<![endif]--><head>

    Код который исправил ситуацию:

    <! DOCTYPE html>
    <!--[if lt IE 7 ]> <html lang="en" class="no-js ie6"> <![endif]-->
    <!--[if IE 7 ]> <html lang="en" class="no-js ie7"> <![endif]-->
    <!--[if IE 8 ]> <html lang="en" class="no-js ie8"> <![endif]-->
    <!--[if IE 9 ]> <html lang="en" class="no-js ie9"> <![endif]-->
    <!--[if (gt IE 9)|!(IE)]><!-->
    <!--[if (gt IE 10)|!(IE)]><!-->
    <html dir="<?php echo $direction; ?>" lang="<?php echo $lang; ?>">
    <!--<![endif]--><head>
     
  15. Gafe62

    Gafe62

    Регистрация:
    11 окт 2013
    Сообщения:
    252
    Симпатии:
    30
    Так у тебя и сам весь сайт кривой, где-то текст уезжает ниже лого, где-то номер разъезжается, советую сам сайт сначала настроить :Smile: