[Помогите] Не работает ЧПУ (ошибка 404)

Тема в разделе "OpenCart", создана пользователем alex_storm, 24 апр 2013.

  1. alex_storm

    alex_storm дизайн, CSS Команда форума

    Регистрация:
    11 дек 2012
    Сообщения:
    1.120
    Симпатии:
    559
    Все привет.
    Пытался настроить ЧПУ на сайте, делал как описывал в функциональных возможностях опенкарта.
    Включил Seopro
    Установил Deadcowseo
    Поставил Seomanager
    Сбросил кеш.

    После этого обычно все работает..
    Но вот попался хостинг, на котором не работает данная конфигурация..
     
  2. kama812

    kama812

    Регистрация:
    30 мар 2013
    Сообщения:
    311
    Симпатии:
    194
    Определяем, читается ли .htaccess: набиваем туда любую чушь — 500-ая ошибка, значит, работает.
    Определяем, включен ли mod_rewrite: пишем в .htaccess строку RewriteEngine On — 500-ю получаем, значит, не подключен.
    в .htaccess пишем
    1. RewriteEngine On
    2. RewriteRule page1.html page2.html
    3. Создаем пару простых страницы, и набираем адрес http://domain.zone/page1.html
    если это всё пашет, то проверь есть ли записи в таблице БД oc_url_alias
    если и там есть, то проверить пашет ли стандартный чпу.
    а тогда уж придется копаться в связках. думаю по одному убивать их и смотреть
     
  3. alex_storm

    alex_storm дизайн, CSS Команда форума

    Регистрация:
    11 дек 2012
    Сообщения:
    1.120
    Симпатии:
    559
    Стандартный ЧПУ работает... Вот в том то и прикол(
    Самое главное, что делаю одно и тоже каждый раз и все нормально, а сейчас тупо не включается..
     
  4. dbunt1tled

    dbunt1tled

    Регистрация:
    18 фев 2013
    Сообщения:
    233
    Симпатии:
    44
    тут на форуме советовали .htaccess Options +FollowSymlinks, надо заменить на Options +SymLinksIfOwnerMatch
     
  5. alex_storm

    alex_storm дизайн, CSS Команда форума

    Регистрация:
    11 дек 2012
    Сообщения:
    1.120
    Симпатии:
    559
    Вообщем по непонятным причинам был отключен RewriteEngine после включения все заработало..
     
  6. VeryGood

    VeryGood

    Регистрация:
    11 дек 2012
    Сообщения:
    216
    Симпатии:
    54
    Не стал создавать дубль темы, но ситуация аналогичная. Не удается запустить SEO.
    Устанавливаю Deadcowseo, вкл. ЧПУ в настройках шопа, генерирую Deadcowseo и в итоге - Ошибка 404.

    Вот содержание .htaccess: