[Помогите] Не работает pop-up изображение в категории

Тема в разделе "OpenCart", создана пользователем Smile-Smile, 19 мар 2014.

  1. Smile-Smile

    Smile-Smile

    Регистрация:
    19 мар 2013
    Сообщения:
    37
    Симпатии:
    1
    Вроде все работало нормально при установке - в категории товара можно было открыть увеличенное изображение не заходя на саму страницу товара.

    А теперь пишет "could not load image" на станице товара все ок.

    В чем может быть причина?

    ЗЫ. Даже полностью переустанавливала движок и тему - то же самое....в разных браузеах и на разных компьютерах.
    Тема
    Pav Bestbuy
    1.5.5.1 ocS
    --- Добавлено, 19 мар 2014 ---
    Сейчас вот файр багом смотрю - оказывается - отправляет неправильный запрос, вместо стандартного www.site.ru/image/data/photo.jpg
    запрашивает www.site.ru/image/data-photo.jpg то есть вместо слеша после папки data ставит "-"...
    Чего делать?
     
    Последнее редактирование: 19 мар 2014
  2. Smile-Smile

    Smile-Smile

    Регистрация:
    19 мар 2013
    Сообщения:
    37
    Симпатии:
    1
    Ну неужели никто не знает, где ковырять? Генерируется неправильная ссылка на изображение и все тут <a href="http://********/image//data-matras-label1.jpg" class="colorbox product-zoom cboxElement" rel="colorbox" title="Матрас «Лабель - 1»"><span class="icon-zoom-in"></span></a>
    --- Добавлено, 20 мар 2014 ---
    Уже замучилась, в файле
    Код:
    <a href="<?php echo $product['href']; ?>"><img src="<?php echo $product['thumb']; ?>" title="<?php echo $product['name']; ?>" alt="<?php echo $product['name']; ?>" /></a>
              <?php if( $categoryPzoom ) { $zimage = str_replace( "cache","", preg_replace("#-\d+x\d+#", "",  $product['thumb'] ));  ?>
              <a href="<?php echo $zimage;?>" class="colorbox product-zoom" rel="colorbox" title="<?php echo $product['name']; ?>"><span class="icon-zoom-in"></span></a>
              <?php } ?>
    Пробовала убирать\подставлять, но получается ерунда...если убрать "cache" то вроде ровно, но вот в папке кэша все фото имеют "хвост" типа data-matras-label1-800x600.jpg

    уффф...намучилась, но решила проблему - все работает!
     
    Lasted edited by : 21 мар 2014
  3. maetus

    maetus

    Регистрация:
    24 фев 2013
    Сообщения:
    216
    Симпатии:
    40
    попробовал ваш метод и убрал "cache" но ничего не получилось, как не работало так и не работает - http://wmasteru.org/threads/после-у...ении-картинки-в-категориях.15082/#post-119521
     
  4. chukcha

    chukcha

    Регистрация:
    9 окт 2014
    Сообщения:
    282
    Симпатии:
    85
    <?php if( $categoryPzoom ) { $zimage = str_replace( "/cache","", preg_replace("#-\d+x\d+#", "", $product['thumb'] )); ?>
    или
    <?php if( $categoryPzoom ) { $zimage = str_replace( "cache/","", preg_replace("#-\d+x\d+#", "", $product['thumb'] )); ?>
     
  5. maetus

    maetus

    Регистрация:
    24 фев 2013
    Сообщения:
    216
    Симпатии:
    40
    Эти два варианта тоже не работают, возможно причина в том что Simon Filters блокирует вывод colorbox