[Решено] Обновление oCStore 0.1.9

Тема в разделе "OpenCart", создана пользователем Shket, 22 сен 2015.

Статус темы:
Закрыта.
  1. Shket

    Shket

    Регистрация:
    21 сен 2015
    Сообщения:
    58
    Симпатии:
    11
    Добрый день !

    Друзья, подскажите пожалуйста такую вещь ..

    Есть магазин, с переписанным специально под него шаблоном и модулями на oCStore 0.1.9 (делалось очень давно, а понадобилось сейчас)

    До какой версии можно безболезненно обновить движек, и есть ли в этом смысл (может были исправлены какие-то серьезные проблемы с безопасностью или были внесены какие другие критические изменения) ?
     
  2. Dotrox

    Dotrox Команда форума

    Регистрация:
    27 ноя 2012
    Сообщения:
    2.053
    Симпатии:
    779
    Безболезненными обновления в ОК бывают редко. А обновлять с одной очень старой версии на другую очень старую версию нет смысла. А на 1.5.6 проще пересоздать, чем обновлять (на вторую версию переходить особого смысла нет, но это в любом случае ещё сложнее будет).
     
  3. Stealth421

    Stealth421

    Регистрация:
    10 дек 2013
    Сообщения:
    108
    Симпатии:
    53
    если все работает и все устраивает, то лучше ничего не трогать
     
  4. skiv14

    skiv14

    Регистрация:
    9 июн 2015
    Сообщения:
    412
    Симпатии:
    159
    Stealth421, сильно стара версия. И модули старые не поддерживаются и новые не выпускают. Сайт-инвалид получается...

    Shket, друг, я посоветую поставить 1.5 или 2.0 и постепенно настраивать по новой. Как настроишь всё - изучай вопрос переноса базы.
    В совсем уж крайнем случае, если домен нормально раскручен - делаешь новый сайт, со старого делаешь переадресацию на новый.
     
  5. Dotrox

    Dotrox Команда форума

    Регистрация:
    27 ноя 2012
    Сообщения:
    2.053
    Симпатии:
    779
    Программный код не изнашивается :Smile: Если всё работает и полностью справляется со своими задачами, оно ещё спокойно 10 лет проработать может.
     
  6. Shket

    Shket

    Регистрация:
    21 сен 2015
    Сообщения:
    58
    Симпатии:
    11
    Там все работает как часы )
    Но вот потребовалось объединить магазин с 1С .. Это единственное, что когда-то давно планировалось как расширение функционала .. Больше ничего делать не нужно будет .
    Старый модуль хоть и есть, но чот не работает )
    Разработчики (вернее магазин, в котором этот модуль покупался) говорят, что этот товар сто лет назад снят с продажи, и ничем помочь не можем ..
    Писать самому - не осилю ..
    А платить кому-то, что бы разобраться в древней версии движка и написать для нее модуль .. тоже как-то не очень .
    --- Добавлено, 23 сен 2015 ---
    Базу можно через модуль импорта \ экспорта перенести - это проще всего
    Больше меня напрягает переделывать шаблон, т.к чтобы все осталось в прежнем виде, нужно брать какой-то другой и пилить его .. С изменившейся структурой движка этот процесс будет не быстрым ..
    Плюс искать альтернативные модули. И устроит ли меня качество их работы тоже вопрос ..

    Жаль, конечно, что все так сложно =)
     
  7. Pelmen2

    Pelmen2

    Регистрация:
    26 янв 2015
    Сообщения:
    169
    Симпатии:
    14
    смотри, старый тоже доводить до ума надо.
    тут просто надо выбрать меньшее из зол: или допилить старый или перепилить новый.

    и так и так допиливать надо.
     
  8. skiv14

    skiv14

    Регистрация:
    9 июн 2015
    Сообщения:
    412
    Симпатии:
    159
    Shket, сейчас с одной проблемой столкнулись, потом другая может возникнуть.
    Подготовьте солому сейчас. Чтоб потом не падать больно.
    Я, на Вашем месте, незамедлительно начал бы работать в этом направлении...

    Сделать изменения в шаблоне имея конечный вариант - это очень упрощает задачу. Как правило, сначала придумывают и потом переделывают существующее. А у Вас же всё готово. И никто пистолет у виска не держит. Остаётся потихоньку двигаться в этом направлении и сделать клона за пару-тройку месяцев.

    Ну или искать исполнителя. И в дальнейшем аналогично...
     
  9. Shket

    Shket

    Регистрация:
    21 сен 2015
    Сообщения:
    58
    Симпатии:
    11
    Спасибо за ответы ! )

    Тогда другой вопрос .. Сейчас существует несколько сборок Опенкарта.
    Если уж делать все заново на новом движке, то какой, по вашему мнению будет оптимальным ?
    Чистый Опенкарт, Окстор, который я использовал раньше, Окшоп или Брокарт .. или еще что-то ?

    Если это важно, то вот вкратце о магазине:
    Число позиций у меня около 500.
    Используются модули оплаты электронными деньгами.
    Всякие плюшки, типа увеличения изображения при наведении, плавное улетание товара в корзину итп
    Плюс нужно подружить магазин с 1С

    Может в какой-то сборке работа с 1С реализована как-то по другому и работает лучше \ проще ?
     
  10. Pelmen2

    Pelmen2

    Регистрация:
    26 янв 2015
    Сообщения:
    169
    Симпатии:
    14
    основа одна, поэтому обмен с 1с должен быть типовой. используйте бесплатный обмен 1c exchange. при необходимости его доведут до ума спецы с известного форума.
    я бы посоветовал окшоп, тут всё что надо есть. всякие фишки типа увеличения изображения зачастую идёт в шаблоне.
    500 позиций - это ниочём любая сборка справится.
     
Статус темы:
Закрыта.