Отличия ocStore 1.5x - 2x

Тема в разделе "OpenCart", создана пользователем moonstyles, 12 авг 2016.

  1. moonstyles

    moonstyles

    Регистрация:
    13 апр 2013
    Сообщения:
    157
    Симпатии:
    7
    Какая версия лучше касательно:
    1. Нагрузки на сервер
    2. Поисковых систем
    3. Стабильности
     
  2. Dotrox

    Dotrox Команда форума

    Регистрация:
    27 ноя 2012
    Сообщения:
    2.044
    Симпатии:
    775
    Если говорить именно про ocStore, а не оригинальный ОК, то особой разницы нет. Но на ocStore в двойке на данный момент есть только 2.1.

    А на счёт двойки в целом - она сейчас всё ещё в активном развитии и каждая следующая версия имеет некоторое количество существенных отличий от предыдущих. Выбирая двойку будьте готовы, что обновиться на следующую версию в ветке будет не намного проще, чем при переходе с 1.5 (если вы смотрите на двойку в плане перспектив).
     
    moonstyles нравится это.
  3. chukcha

    chukcha

    Регистрация:
    9 окт 2014
    Сообщения:
    281
    Симпатии:
    85
    По нагрузке
    2-ка из коробки чуть быстрее - добавлены нужные индексы

    Чуть - это чуть.. а не то что ах!!!
    Т.е. все запросы остались в том же виде.


    ПС - ocStore 2.1.0.2

    Стабильность - по крайней мере если взять последний релиз, то жалоб нет

    Переходить не имеет смысла
    Если вы заморочены на адаптивнсти сайта, то подбирайте шаблон для 1.5
     
    samuel_L и moonstyles нравится это.
  4. moonstyles

    moonstyles

    Регистрация:
    13 апр 2013
    Сообщения:
    157
    Симпатии:
    7
    Да з адаптивностю всё в норме. Стоит journal 2.7.3
     
  5. chukcha

    chukcha

    Регистрация:
    9 окт 2014
    Сообщения:
    281
    Симпатии:
    85
    Не дергайтесь
    Как минимум еще с год-два.
    Ничего такого, чтобы вам дало профит там пока нет
    Тем боле, что и 3.0 на подходе.

    Наличие модулей для 1.5 есть, и практически под все...

    Платежные системы - сами модули под двойку делать не будут, а под 1.5. есть реализации..

    Да.. но под 2-ку, есть реализации, которых нет под 1.5 и их будет больше, потому что поддерживать версии становится очень накладно.

    Но.. я новый проект желаю на 2.3, но это потому что я знаю, что я это смогу.
     
    skiv14 нравится это.
  6. Dotrox

    Dotrox Команда форума

    Регистрация:
    27 ноя 2012
    Сообщения:
    2.044
    Симпатии:
    775
    С выходом тройки, которая вдруг стала следующей версией после 2.3, история повторится, так что самый правильный совет - это как раз не дёргаться :Smile:
    Да и на счёт количества модулей под двойку - это ещё вопрос: в 1.5 почти все модули без vQmod могли из коробки работать с любой версией в ветке (да и с vQmod проблемы возникали не всегда). А в случае с двойкой я не представляю какой бы модуль, даже без модификатров, смог бы работать сразу на всех версиях от 2.0 до 2.3. А потому суммарное количество модулей под двойку, может, и будет расти до выхода тройки, но совсем не факт, что получиться найти нужный модуль именно под конкретную версию.
    Особенно в этом плане "повезло" тем, кто с разбегу поставил себе 2.0.
     
  7. samuel_L

    samuel_L

    Регистрация:
    6 окт 2012
    Сообщения:
    214
    Симпатии:
    131
    Оставлю свои 2 слова.
    Долгое время юзал 1.5.6.х и думал ни ногой на 2ку. Зачем? Модулей больше (тогда было) и стабильно уж точно.
    Со временем опробовал 2ку, а именно 2.1.0.1-2.1.0.2 и остался очень доволен. Версия стабильная, большинство модулей под нее перенесено (под 2.2 уже меньше, под 2.3 тем более, на данный момент).

    Быстрее, это точно (без особых бубнов и "отлова медленных запросов").
    По СЕО - из коробки весь опенкарт кривой и не соответствует требованиям поисковиков. Прооблема решается пачкой модулей. В ТОПе имею клиентские сайты как на 1.5, так и на 2.1.
    Приятнее в админке, уже на бутстрапе (если сравнивать по крайней мере дефолт).

    Отмечу, что я не программист и мнение мое именно с позиции НЕпрограммиста.
     
    Последнее редактирование: 15 авг 2016
  8. Dotrox

    Dotrox Команда форума

    Регистрация:
    27 ноя 2012
    Сообщения:
    2.044
    Симпатии:
    775
    Ну, админка - спорный вопрос. Не сказал бы, что старая была шикарной, но и новая не лучше, разве что адаптивная теперь.
    Если б взяли AdminLTE и то лучше было бы (а текущий шаблон админки был куплен именно у автора AdminLTE).
     
  9. alexgribanova

    alexgribanova

    Регистрация:
    23 авг 2016
    Сообщения:
    14
    Симпатии:
    14
    Под 1.5.X шаблонов на бутстрапе не найдешь.
     
    pitbull1972 нравится это.
  10. Dotrox

    Dotrox Команда форума

    Регистрация:
    27 ноя 2012
    Сообщения:
    2.044
    Симпатии:
    775
    Если вы про админку, то плохо искали - они есть, хоть и не много, а если про витрину - это флуд (таких шаблонов сотни, если не тысячи).
     
  11. alexgribanova

    alexgribanova

    Регистрация:
    23 авг 2016
    Сообщения:
    14
    Симпатии:
    14
    Не сочтите за труд подсказать где поискать такие шаблоны?
     
    pitbull1972 нравится это.
  12. samuel_L

    samuel_L

    Регистрация:
    6 окт 2012
    Сообщения:
    214
    Симпатии:
    131
    там же где всё ищут)
    пример
    Код:
    http://www.opencart.com/index.php?route=extension/extension/info&extension_id=13691&filter_search=admin%20theme&page=4
     
    Dotrox и pitbull1972 нравится это.