Kredov long

[Помогите] При экспорте/импорте HTML символы меняются на знак вопроса. Как исправить?

Тема в разделе "OpenCart", создана пользователем Voland70, 15 июл 2014.

  1. Voland70

    Voland70

    Регистрация:
    29 июн 2014
    Сообщения:
    74
    Симпатии:
    3
    При экспорте-импорте данных через CSV файл, HTML – сущности (символы дробей, градусов, в «квадрате», в «кубе»), - заменяются символом знак вопроса. На страницах сайта вместо необходимых символов - ?.

    Заметил, что эта неувязка происходит после экспорта – импорта в CSV. Когда вставляю HTML-через редактор CMS – всё в порядке.

    Много времени и сил было потрачено на назначение атрибутов товарам – Метры кубические , метры квадратные, ½, ¾, градусы цельсия и т.д. – набивал неделю, - сделал красиво! И после экспорта/ импорта – вместо символов знак -?

    Вопрос касается наверное не только OpenCart, Ocstore, но вопросы возникли при модерировании сайта на Ocstore. Проблема скорее в отсутствии знаний и кривых руках. Устал от плясок с бубном, и гугл не помог, надеюсь на Вашу помощь!

    Как избежать потери символов?
     
  2. Dmitriy555

    Dmitriy555

    Регистрация:
    9 июл 2014
    Сообщения:
    13
    Симпатии:
    0
    Вам необходимо сохранить документ в кодировке UTF-8 без BOM
     
  3. Voland70

    Voland70

    Регистрация:
    29 июн 2014
    Сообщения:
    74
    Симпатии:
    3
    Спасибо!
    Ради эксперемента сделал выгрузку, открыл в Excel, сохранил файл, затем заново открыл его Notepad++ -> преобразовать UTF-8 без BOM->сохранить. И теперь при экспорте все в порядке, все символы отражаются.

    Получается Excel не может сохранять файл CSV в без BOM ? Приходится делать лишние телодвижения...