[Помогите] Проблема с кодировкой

Тема в разделе "OpenCart", создана пользователем five555, 15 май 2015.

  1. five555

    five555

    Регистрация:
    18 янв 2014
    Сообщения:
    221
    Симпатии:
    147
    Добрый день!
    Есть две проблемы с кодировкой:
    1. В каналах продвижения создаётся Google Base по ссылке https://sfera.by/index.php?route=feed/google_base, но если ввести ссылку в браузере - возникает проблема с кодировкой.
    Код:
    <title>Sfera.by</title><description>Онлайн магазин &quot;Сфера&quot; - широкий выбор аудио и видеотехники для дома и автомобиля, автомобильных сигнализаций и охранных систем, аксессуаров. Вся техника имеет официальную гарантию производителя.</description>
    2. В инструментах для вебмастеров гугл метаописание отображает так:
    [​IMG]
    Я так понимаю это тоже проблема с кодировкой.
    Проверил это описание копированием и вставкой в notepad++ с самой страницы, с кода страницы, с БД, с админки где заполняется поле - везде кодировка в UTF-8 (без BOM)

    Подскажите, где искать проблему. Не перелопачивать же 10 000 - 15 000 файлов... Или проверять абсолютно всё? Может есть какой-нибудь вариант для автоматизации этого процесса? при переходе на дефолтный шаблон тоже самое, при отключении в админке всех модулей тоже ничего не меняется.
     
    Последнее редактирование: 15 май 2015
  2. Pant

    Pant

    Регистрация:
    6 фев 2013
    Сообщения:
    121
    Симпатии:
    11
    По поводу 2 проблемы, сталкивался с этим, дело оказалось в том что тема оформления сайта была краденой, и там были некоторые файлы не кодировки UTF-8. Точно какие файлы не помню.
     
  3. dexteron

    dexteron

    Регистрация:
    12 окт 2012
    Сообщения:
    46
    Симпатии:
    14
    Какая у вас кодировка стоит в шаблоне (meta charset)?
     
  4. five555

    five555

    Регистрация:
    18 янв 2014
    Сообщения:
    221
    Симпатии:
    147
    UTF-8