[Решено] Проблема с обновлением через 1 click Upgrade

Тема в разделе "PrestaShop", создана пользователем Maimeri, 31 июл 2016.

Статус темы:
Закрыта.
  1. Maimeri

    Maimeri

    Регистрация:
    17 окт 2015
    Сообщения:
    36
    Симпатии:
    4
    Добрый день.
    Возник вопрос по поводу обновления prestashop с 1.5.5.0 до 1.6.1.6
    При обновлении через 1 click Upgrade возникает ошибка

    "You are using PHP 5.3.28 version. Soon, the latest PHP version supported by PrestaShop will be PHP 5.4. To make sure you’re ready for the future, we recommend you to upgrade to PHP 5.4 now!"

    И все. Дальше ничего не происходит.
    Возможности обновить PHP до требуемого нет.

    Собственно вопрос. Может есть какой то альтернативный способ обновления престы до актуальной версии?
     
  2. $iD

    $iD Команда форума

    Регистрация:
    13 мар 2012
    Сообщения:
    3.349
    Симпатии:
    1.380
    нет конечно, как вы себе это представляете? в новой версии престы используются фичи языка php, которых нет в 5.3.
     
  3. Maimeri

    Maimeri

    Регистрация:
    17 окт 2015
    Сообщения:
    36
    Симпатии:
    4
    Хорошо, тогда почему при обновлении на денвере с версией PHP 5.3.13 у меня нормально обновилось до 1.6.1.6?
    --- Добавлено, 31 июл 2016 ---
    Тогда встречный вопрос. Как мне произвести переход на более новую престу оставаясь на PHP 5.3.28?
     
  4. $iD

    $iD Команда форума

    Регистрация:
    13 мар 2012
    Сообщения:
    3.349
    Симпатии:
    1.380
    вообще если речь идёт только о 1.6.1.x - то она работает на php выше 5.2

    а ваше сообщение пишет, что в скором времени (видимо имеется ввиду 1.7) движок перестанет поддерживать 5.3.
    и рекомендует обновиться сразу.

    почему у вас на хостинге упало - я не знаю. Всн ошибки можно найти в логах апача (если предоставляется хостингом)
    ответ чуть выше. преста 1.6 поддерживает php 5.2. Когда выйдет presta 1.7 вы уже не сможете пользоваться ей на 5.3.
     
  5. Maimeri

    Maimeri

    Регистрация:
    17 окт 2015
    Сообщения:
    36
    Симпатии:
    4
    Вообще странное дело
    Вообще странное дело. Если на денвере при нажатии на кнопку Upgrade PrestaShop now! переходит на окно обновления, то на основном сервере выдает надпись "Settings update successful!"

    Не понимаю в чем может быть дело.
    Опять повторюсь.
    Может есть какой то альтернативный способ обновления престы до версии 1.6 без модуля 1-click Upgrade ?
    --- Добавлено, 31 июл 2016 ---
    Вопрос решился удалением модуля "Запрос обратного звонка". После удаления 1 click Upgrade запустился.
     
    rombol нравится это.
Статус темы:
Закрыта.