[Помогите] Пропали CSS после установки SEO PRO

Тема в разделе "OpenCart", создана пользователем opalko, 19 янв 2015.

  1. opalko

    opalko

    Регистрация:
    23 дек 2014
    Сообщения:
    151
    Симпатии:
    9
    Беда, господа) Установил SEO PRO на opencart 1.5.5.1, настроил, внёс изменения в .htaccess (если изменения удалить, ошибка 404) Уже запарился. Вот что написал в .htaccess
     
  2. Толик

    Толик

    Регистрация:
    14 апр 2014
    Сообщения:
    37
    Симпатии:
    6
    .htaccess.txt переименовал в .htaccess ? какая сборка стоит ? какие настройки выставлены ?
     
  3. opalko

    opalko

    Регистрация:
    23 дек 2014
    Сообщения:
    151
    Симпатии:
    9
    opencart 1.5.5.1, с шаблоном, вот http://cool.pp.ua, настройки в точности как написано в инструкции, может стили к ссылкам привязаны, как проверить?
     
  4. cereberlum

    cereberlum

    Регистрация:
    26 май 2013
    Сообщения:
    740
    Симпатии:
    267
    чувствую что в шаблоне хедера (каталог) не хватало всего лишь этого <base href="<?php echo $base; ?>" /> сразу после вызова title можно добавить css не пропадает, просто путь начинает неверно определяться.
    Код:
    <title><?php echo $title; ?></title>
    <base href="<?php echo $base; ?>" />
     
    opalko нравится это.
  5. opalko

    opalko

    Регистрация:
    23 дек 2014
    Сообщения:
    151
    Симпатии:
    9
    Благодарю Вас за помощь, но, к сожалению, не могу это проверить, восстановился из бэкапа. До этого пробовал изменить относительные пути к стилям и скриптам, на абсолютные, но количество переадресаций привело к тому, что хостинг заблокировал IP. Решил не двигаться дальше и отказался от Seo Pro.