Странности Joomla 1.5

Тема в разделе "Joomla", создана пользователем abrodski, 12 окт 2015.

  1. abrodski

    abrodski

    Регистрация:
    4 фев 2015
    Сообщения:
    9
    Симпатии:
    0
    Здравствуйте,

    У меня возникла странная проблема. Собственно, их две. Одна -- решаемая, а вторую я сам не могу осилить. Но может быть это как то связано...
    Проблема № 1:
    Для того, чтобы в админке сохранить что либо надо кликнуть 2-3 раза. С первого раза, чаще всего, ничего не меняется.
    Проблема № 2:
    У меня стоит VirtueMart 1.1
    Там есть способ оплаты ROBOKASSA
    Там вообще непонятно что происходит. Там где надо ввести пароль и т.д., вместо этого какая то ерунда сама откуда то берется (похоже на PHP код).
    Типа < ? ECHO и т.д. >
    Это же система сама автоматом прописывает и в соответствующем конфигурационном файле PHP.
    Само собой, что в магазине оплата при помощи системы ROBOKASSA не работает (там вместо ссылки на интерфейс Робокассы, я получаю PHP-шный текст, состоящий из разных параметров.
     
  2. websbk

    websbk

    Регистрация:
    9 окт 2015
    Сообщения:
    11
    Симпатии:
    1
    Скорей всего компонент VirtueMart 1.1 не совместим с веткой 1.5
     
  3. abrodski

    abrodski

    Регистрация:
    4 фев 2015
    Сообщения:
    9
    Симпатии:
    0
    Спасибо за ответ!

    Да нет, прекрасно совместим. Собственно, Virtuemart 1.1 под J1.5 и делался... И у меня 2-3 года назад всё работало (потом я пару лет не проверял модуль оплаты ROBOKASSA).
    Знаете, у меня что-то подозрение, что может старая Joomla не очень дружит с PHP 5.5, который у меня стоит на сервере?
    Те симптомы, о которых я писал вначале, могут быть как-то с этим связаны?
     
  4. Zulus

    Zulus Команда форума

    Регистрация:
    20 дек 2012
    Сообщения:
    682
    Симпатии:
    686
    Может и не дружить. Вернее, если была вначале одна версия, а потом сменилась, то иногда может вызвать проблемы в работе.
    Еще есть мысль что у робокассы мог смениться API, и в том случае если модуль работает через API и за это время модуль не обновлялся, то корректно работать он не будет.
     
  5. abrodski

    abrodski

    Регистрация:
    4 фев 2015
    Сообщения:
    9
    Симпатии:
    0
    Спасибо за Ваш ответ! Я почти уверен, что сайт делал на PHP 5.3 (хотя тогда я и не обращал на это внимание). То был 2012 год и судя по выходу версий PHP, то так оно и было. Тем паче, что официально, как я понимаю, J1.5 гарантированно работает до этой версии. А теперь я уже готовый сайт перенес на PHP 5.5
    И что теперь делать -- убирать PHP 5.5 и ставить 5.3 (но, боюсь, как бы опять чего не вышло, там же еще и связка с MySQL и Apache).
    Может быть это вопрос для Линукс форума (Ubuntu 14.04).
    Может стоит потратить время и силы на установку J2.5 с Virtuemart 2...?
     
  6. Zulus

    Zulus Команда форума

    Регистрация:
    20 дек 2012
    Сообщения:
    682
    Симпатии:
    686
    Вы не показали что у вас за сайт, покажите, так легче будет что-то посоветовать.
    Но однозначно надо уходить с джумлы 1,5 (причем еще пару лет назад как надо было), с 2,5 лучше то же не заморачиваться, так как поддержка уже и на нее закончилась (скоро будет год как не поддерживается). Если делать на джумле, то с последней версией 3-ки.
    Но, здесь вот в чем фишка, виртумарт это ведь монстр неповоротливый - только в топку его :Diablo:.
    Если у вас только интерент магазин, то я бы вообще отказался от джумлы и посмотрел в сторону опенкарта. Движок бесплатный, модулей и шаблонов море (относительно недорогих), а здесь, на форуме, так вообще можно без финансовых затрат получить и поддержка / сообщество приличное, практически все вопросы можно решить.
    Если же все таки джумла, то мне больше нравится mijoshop - связка джумлы с опенкартом, а так же Hikashop.
     
  7. abrodski

    abrodski

    Регистрация:
    4 фев 2015
    Сообщения:
    9
    Симпатии:
    0
    Спасибо за Ваш ответ!

    Нет, никуда я уходить не буду. Меня связка Джумла Virtuemart вполне устраивает (когда они работают вместе). Уходить -- это значит переучиваться заново. А у меня на это нет ни лишнего времени, ни особого желания.
    Не нужна мне никакая поддержка, если всё работает. Не знаю, может проблема в несовместимости старой Джумлы и PHP 5.5 Так что, пользуясь J2.5 с Virtuemart'ом 2 я как бы убираю эту опцию из списка потенциальных проблем на сайте.
    Пока не выйдет LTS 3.5 для меня третья Джумла не существует. Это раз...
    А второе -- это то, что мне удобней и эффективней использовать видео курсы, а пока они и серьезная литература появляются, проходит года два.
     
  8. Damowoy

    Damowoy

    Регистрация:
    1 авг 2013
    Сообщения:
    3
    Симпатии:
    0
    Проверте данные в инспекоре кода, что и как реогирует, а также куда сылается