[Помогите] Форма оплаты сразу не подгружается в Simlpe 4.2.5

Тема в разделе "OpenCart", создана пользователем Grek, 27 июл 2015.

  1. Grek

    Grek

    Регистрация:
    18 янв 2013
    Сообщения:
    172
    Симпатии:
    18
    Подскажите, такая беда: настроил через Simple простое оформление заказа, но никак не пойму 2 момента:
    1) Сразу не подгружается форма оплаты. То есть когда пользователь оформляет заказ, то под методом оплаты по умолчанию (например, перевод денег на карточку), текст с номером карточки, на который надо перевести деньги (форма оплаты) сразу не подгружается. Вот если заполнить все поля пользователя, а потом поклацать по разным методам оплаты, тогда все нормально подгружается для каждого метода оплаты (выводится снизу сразу под блоком метода оплаты). Никак не пойму, как заставить заработать форму сразу при загрузке оформления заказа.
    2) беда, связанная с 1м пунктом - при выборе некоторых методов оплаты при нажатии на кнопке "Оформить заказ" появляется текст с инструкциями, и кнопка меняется на "Подтвердить оформление заказа". И только по второму нажатию заказ оформляется. При работе на планшете это довольно не удобно, так как пользователь думает, что уже оформил заказ по первому нажатию.
    Прошу помощи у тех, кто с таким сталкивался - как пофиксить и упростить оформление заказа.
     
  2. Pelmen2

    Pelmen2

    Регистрация:
    26 янв 2015
    Сообщения:
    169
    Симпатии:
    14
    Обрати внимание на настройку, обновления метода после изменения определённых полей.
    По второму пункту похоже это сделано намеренно, тоже надо посмотреть в настройках, типа подтверждение оформления.
     
  3. Grek

    Grek

    Регистрация:
    18 янв 2013
    Сообщения:
    172
    Симпатии:
    18
    А где найти эти настройки? В общих настройках заказа Simple 4.2.5 такого не нашел, да и подтвержение оформления заказа тоже в настройках нигде не вижу.