[Помогите] поле model в категориях выводит "null"

Тема в разделе "OpenCart", создана пользователем AnOcToJI, 24 сен 2013.

Статус темы:
Закрыта.
  1. AnOcToJI

    AnOcToJI

    Регистрация:
    28 дек 2012
    Сообщения:
    293
    Симпатии:
    186
    при попытке вывести в категории model почему-то выскакивает вместо содержания "null" и понять в чём причина не могу, изначально при обновлении странице или заходе на секунду прогружаются реальные данные но потом отрабатывает яваскрипт и выводит "null" в чём может быть проблема?
     
  2. Baco

    Baco Антихронофаг Команда форума

    Регистрация:
    9 окт 2012
    Сообщения:
    648
    Симпатии:
    327
    В функции display (javascript внизу страницы), там надо добавить в отображение обоих видов (список \сетка) проверку данных, типа:
    Код:
    var model = $(element).find('.model').html();
               
                if (model != null) {
                    html += '<div class="model">' + model + '</div>';
                }
    Но сперва при выводе модели, добавить в класс: <div class="model"><?php echo $product['model']; ?></div>
     
    AnOcToJI нравится это.
  3. AnOcToJI

    AnOcToJI

    Регистрация:
    28 дек 2012
    Сообщения:
    293
    Симпатии:
    186
    в первую очередь и было сделано, но потом убрал
    Код:
    var model = $(element).find('.model').html();
          
                if (model != null) {
                    html += '<div class="model">' + model + '</div>';
                }
    единственно отличие с этим и без - это то, что:
    с, не выводится ничего вообще(но так же на секунду появляются реальные данные)
    без, выводится "null"
    --- Добавлено, 24 сен 2013 ---
    Большое спасибо, Baco.
    Дело оказалось в FilterPro
     
    Lasted edited by : 24 сен 2013
Статус темы:
Закрыта.