1.5.3.1 или 1.5.5.1

Тема в разделе "OpenCart", создана пользователем seregha, 9 апр 2013.

  1. seregha

    seregha

    Регистрация:
    8 апр 2013
    Сообщения:
    80
    Симпатии:
    17
    Ранее имел дело только с Joomla.
    Много готовых решений и модулей увидел в OpenCart. Пересмотрел 10 страниц по поиску на форуме. Не решил в выборе в версии.
    Новый проект начать с 1.5.3.1 или 1.5.5.1? Разбираться придётся в обоих версиях.
    Магазин до 1000 позиций.

    Суть вопроса: смогу ли без проблем перейти с 3.1 на 5.1 через полгодика? на 3.1 в открытом доступе побольше модулей, от этого и отталкиваюсь
     
  2. noobie

    noobie

    Регистрация:
    27 мар 2013
    Сообщения:
    173
    Симпатии:
    22
    Я бы рекомендовал начать с золотой середины т.е. 1.5.4.1
    более стабильна чем 5.1 и более надежна чем 3.1
     
  3. ergoline

    ergoline

    Регистрация:
    23 ноя 2012
    Сообщения:
    214
    Симпатии:
    22
    через полгода будет или 1571 или 1610 или 2)
    главной, я считаю проблему совместимости модулей и шабов.
    и вот исходя из этого, на 1 месте по количеству всего возможного 1513, потом 1531
    а разница между ними не очень велика, если следить чего там надорабатывали)
    а на счет безопастности и защиты... то, что они защищают, у нас будет лет через 5 может быть))))
    а если кто захочеть сломать именно ваш шоп - поверьте - сломают
     
  4. Berserk163

    Berserk163

    Регистрация:
    16 фев 2013
    Сообщения:
    53
    Симпатии:
    22
    Думаю это должно зависеть еще от ваших навыков. Если вы не плохо ориентируетесь в php, sql, html, js и css, можно смело ставить 1.5.5.1, т.к. в большинстве случаев несовместимость модуля и новой версии OC уже не будет играть такой проблемы.
     
  5. seregha

    seregha

    Регистрация:
    8 апр 2013
    Сообщения:
    80
    Симпатии:
    17
    я планирую купить шаблон, который понравился... или через складчину...если не соберутся люди...проще самому...слишком нетерпелив...
    Sellya подходит как на 1.5.3.1 так и на 1.5.5.1... при обновлении Opencart надеюсь проблем не будет.. тем более что глубоко в код я не полезу =)

    ввиду того, что это будет больше витрина, чем шоп...ломать его захочет только начинающий ломака =)

    а вот для себя всякие плюшечки добавлять всегда хочется... на 1.5.3.1 выбор побольше...
    --- добавлено: Apr 9, 2013 10:02 AM ---
    плохо.... точнее лет 6 назад был ближе... теперь считаю, что могу отложить "для чайников", но начну изучать с раздела "для начинающих"...
    поэтому удобная админка меня тоже привлекла на opencart
     
  6. noobie

    noobie

    Регистрация:
    27 мар 2013
    Сообщения:
    173
    Симпатии:
    22
    Поверьте мне я только недавно это прошел. Задавал глупые вопросы что такое шаблон и что такое движек :Smile:
    Но очень быстро въехал что да как.
    Почитайте описания файлов шаблона попробуйте найти и поменять в нем что то простое например цвет меню и поймете.
    Мое ИМХО что хозяин сайта должен или платить специалисту или сам разобратся с внутренностями. Сделать абы как не понимая что ты делаешь - путь в никуда.
     
  7. seregha

    seregha

    Регистрация:
    8 апр 2013
    Сообщения:
    80
    Симпатии:
    17
    думаю, мои знания немножко глубже.. =) возможно я недооценил.... просто не хотел бы переоценить свои возможно, а потом дурацким вопросом получить море критики и никакой помощи...
     
  8. noobie

    noobie

    Регистрация:
    27 мар 2013
    Сообщения:
    173
    Симпатии:
    22
    Ну тем более.
    Форум для того и есть что б задавать вопросы в том числе и дурацкие (хотя предварительно лучше поиском попробовать - многие вопросы решались.)

    Почитайте для начала FAQ http://wmasteru.ru/threads/Настройки-оптимизации-фичи-статьи-для-opencart.2219/

    увидите что можно настраивать и как.

    По модулям открою главный секрет


    Вы скажите какие именно вам нужны модули для 1.5.3.1 и которых не существует например для 1.5.4.1 ocStore?
    Я все же перешел на чистый 1.5.5.1 применил русификаторы почистил БД от ненужных вещей поставил и настроил SEO.
    Но у меня нет желания поставить как можно больше модулей а только те что реально нужны посетителям магазина а не его админу :Smile:
     
  9. seregha

    seregha

    Регистрация:
    8 апр 2013
    Сообщения:
    80
    Симпатии:
    17
    главный секрет меня приятно порадовал, как и раздел покупки в складчину... полезная функция для форума =)
    я остановился на русификации 5.1 и понял, что сыровато =)

    на локальном я уже сделал первые наброски на пару дней...в том числе наполнив ручками около 200 товаров... я конечно понимаю, что это не очень большой кусок работы, но уже жалко его терять... обновление до 4.1 ocStore возможно без потерь?(в код не лазил) или перенос через экспорт/импорт... тем более что через эксель он корявенький...
     
  10. noobie

    noobie

    Регистрация:
    27 мар 2013
    Сообщения:
    173
    Симпатии:
    22
    Вот с товарами это вы явно поспешили. Нужно сразу настроить все а потом в последнюю очередь товары импортнуть.
    Я себе вообще скрипт написал который бекапит движ и БД. Т.е. настроил кое что новое или модуль поставил - проверил - сделал бекап. Непонравился результат - такой же скрипт белает восстановление БД и файлов. Дабы каждый раз не ставить все с нуля.
    И вот так небольшими шагами двигаться.
    Это из личного опыта.
    Т.е. вкратце так -
    1) Ставим двиг + русификацию.
    2) Ставим модули не вляющие на дизайн (vqmod, SEO, и т.д.)
    3) Ставим шаблон.
    4) доставляем остальные модули + тюнингуем сервер.
    5) Добавляем товары.

    Единственное можно добавить немного товаров для оценки диза перед 3 этапом. Штук 16 хватит.
     
  11. seregha

    seregha

    Регистрация:
    8 апр 2013
    Сообщения:
    80
    Симпатии:
    17
    шикарно...пошаговая инструкция - вот что мне надо =)
    я почитал раздел идеальной сборки... конечно универсального инструмента нет... но можешь уточнить парочку своих инструментов...
    1. для бэкапа... желательно 3.1 и 5.1 чтобы работал... или ручками?
    2. тюнингуем сервер =)
     
  12. noobie

    noobie

    Регистрация:
    27 мар 2013
    Сообщения:
    173
    Симпатии:
    22
    1. Смотри. Я настраиваю на локальном сервере с XAMPP
    и для бекапа написал простейший скрипт. обычный .bat
    Т.е. создаем папку где угодно с любым именем туда кидаем батник и архиватор 7z.exe 7z.dll
    в батнике пишем нечто
    Код:
    C:\XAMPP\mysql\bin\mysqldump -u root -pПАРОЛРУТА имябазы >dump.sql
    C:\XAMPP\xampp_stop.exe
    7z.exe a backup_site.7z C:\XAMPP\htdocs\имясайта\
    7z.exe a dump.7z dump.sql
    del dump.sql
    C:\XAMPP\xampp_start.exe
    т.е. делаем дамп - стопим сервак- пакуем файлы - пакуем дамп - удаляем лишнее - стартуем заново
    Без разницы какая версия. Делается полный бекап и файлов и БД. (Нюанс если переносите на совсем новый хостинг то нужно первый раз создать базу и пользователя руками).


    для восстановления напишите похожее только учитывайте что сразу старт БД потом залить дамп. ну вообщем включить логику.
    Если совсем никак пиши дам и восстановление.

    2. Сервер тюнинговать уже лучше на хостинге. Это имеется ввиду подключать разные улучшалки кеширования или настраивать БД по мануалу Yuriy_Z
     
  13. seregha

    seregha

    Регистрация:
    8 апр 2013
    Сообщения:
    80
    Симпатии:
    17
    ночью попробую...если не получится дам знать =)
    спс за совет мануал...

    чтобы немного резюмировать, с безопасным тестом/бэкапом постараюсь сегодня разобраться...но на Ваш взягляд, мне стоит начать с 0 на 5.1? при условии, что я собираюсь ставить на универсальный шаблон для обоих версий...и модули, не влияющие на дизайн, есть в обеих версиях...к сожалению до "доставляем остальные модули + тюнингуем сервер" я пока не дошёл =)
     
  14. 130983

    130983

    Регистрация:
    10 дек 2012
    Сообщения:
    168
    Симпатии:
    145
    на самом деле 1.5.5.1 в данной линейке последняя, сейчас разрабатывается 2.0 то есть очевидно, что там будет совершенно все подругому. Ну а как уже заметили, что 1.5.5.1 сыроватая (а приводить ее в порядок просто бесмысленно), то естественно лучше выбирать наиболее стабильную версию - ocstore 1.5.4.1
     
  15. seregha

    seregha

    Регистрация:
    8 апр 2013
    Сообщения:
    80
    Симпатии:
    17
    похоже по версии я понял предпочтения большинства...а почему именно все стартуют с ocStore?
     
  16. noobie

    noobie

    Регистрация:
    27 мар 2013
    Сообщения:
    173
    Симпатии:
    22
    Минимальные изменения от оригинала (т.е. подходят модули и темы от оригинала). Стабильная версия (в отличии от 5.1). Сразу идет русификация и СЕО в комплекте. Что еще нужно для старта :Smile:
     
  17. seregha

    seregha

    Регистрация:
    8 апр 2013
    Сообщения:
    80
    Симпатии:
    17
  18. glad

    glad

    Регистрация:
    7 ноя 2014
    Сообщения:
    15
    Симпатии:
    0
    Имеет значение для выбора Ocstore или Opencart, если магазин будет работать в Германии?
     
  19. zamalatb

    zamalatb

    Регистрация:
    29 апр 2014
    Сообщения:
    113
    Симпатии:
    31
    Перейти то сможешь, но будет так влом) я за полгода так вручную перековырял свой магазин, что переносить это на новую версию движка для меня как страшный сон! Работает норм и отлично, зачем эта погоня за версиями)
    --- Добавлено, 29 ноя 2014 ---
    Решайте сами) Отличия: