[Помогите] JV_QuickOrder не работает

Тема в разделе "OpenCart", создана пользователем perepela21, 17 ноя 2013.

  1. perepela21

    perepela21

    Регистрация:
    9 ноя 2012
    Сообщения:
    252
    Симпатии:
    87
    Здравствуйте.
    установил JV_QuickOrder с исправлением от сюда

    сделал как положенно закинул исправленный файл контроллера, закинул вмод файл появилась кнопка но только где сам товар, при ее нажатии не чего не происходит. Закинул родной кодированный файл контроллера кнопка появилась везде, на главной в катигориях и в товаре. Кнопка стала работать но требует файл лицензии.
    при просмотре раскодированого файла контроллера при помощи phpDesigner показывает синтаксическую ошибку на строчку 50
    конкретней
    ( $data['product_id'] );
    $product_info = ;

    if ($product_info) {
    if ($product_info['minimum'] < 1) {
    }
    в чем можит быть проблема или можит только у меня не работает?
     
  2. biolion

    biolion

    Регистрация:
    27 окт 2013
    Сообщения:
    303
    Симпатии:
    94
    У меня тоже не работает. Пробовал Вашу версию, и предыдущую тоже самое, кнопка есть но толку от нее нет (
     
  3. ingenerks

    ingenerks

    Регистрация:
    25 окт 2012
    Сообщения:
    254
    Симпатии:
    79
    Аналогичная проблема. При клике на кнопку ничего не происходит. Хоть с заменой файла, хоть без замены. Пробовал и на локальной машине и на хосте.
     
  4. alex5151

    alex5151

    Регистрация:
    15 ноя 2012
    Сообщения:
    165
    Симпатии:
    26
    пробовал разные версии 2.85 и 2.94 - аналогичная проблема. 2.75 - работает
     
  5. Dotrox

    Dotrox Команда форума

    Регистрация:
    27 ноя 2012
    Сообщения:
    2.054
    Симпатии:
    779
    Отредактируйте строку с $product_info = ;
    PHP:
    $product_info $this->model_catalog_product->getProduct($data['product_id']);
     
    Moonfox и perepela21 нравится это.
  6. perepela21

    perepela21

    Регистрация:
    9 ноя 2012
    Сообщения:
    252
    Симпатии:
    87
    спасибо, но как кажится проблема не только в этой строчке. Если в глядется во весь код то ниже заметил что стоят скобки ((( ))) вроде так не понятно, что они открывают и закрывают.
    файл раскодирован не полностью походу дела к сожалению.
    впихнул файл контроллера от версии 2.75 заработало. Но явно не все функции будут работать от версии 2.94
     
  7. cereberlum

    cereberlum

    Регистрация:
    26 май 2013
    Сообщения:
    740
    Симпатии:
    267
    Позволю себе поднять темку. Есть у кого-нибудь или старые версии без ионкуба, или вылеченные новые? Мне не то чтобы жалко 365р. просто не имею желания светить автору дополнения домен, как и в принципе на майопенкарт светить ни чего не хочу.
     
  8. skazis

    skazis

    Регистрация:
    30 окт 2013
    Сообщения:
    9
    Симпатии:
    0
    Установил версию 2,75 на Ocstore 1.5.5.1.1? вроде установилось норм. Только при оформлении заказа ошибка "Произошла ошибка при формировании заказа. Пожалуйста, попробуйте ещё раз или свяжитесь с нами" С чем может быть связано?
     
  9. KEH

    KEH

    Регистрация:
    2 июл 2013
    Сообщения:
    204
    Симпатии:
    28
    Та же проблема. Или версию 2,75 интегрировать в Opencart 1.5.5.1 невозможно?
     
  10. Toliamba

    Toliamba

    Регистрация:
    27 янв 2013
    Сообщения:
    191
    Симпатии:
    44
    А как насчет складчины?Или там активатор на отдельный домен?