side banner

Тема в разделе "OpenCart", создана пользователем crystal_girl, 17 июн 2013.

  1. crystal_girl

    crystal_girl

    Регистрация:
    28 май 2013
    Сообщения:
    4
    Симпатии:
    0
    Привет всем!

    Скачала модуль http://www.opencart.com/index.php?route=extension/extension/info&extension_id=8796
    Но есть проблема - если в админке выбираю layout-default то банера вообще нет на сайте, а если layout-home то показывает ошибку:
    Notice: Error: Could not load controller module/side_banner! in /home/dmidlv/www_domains/brandstore.lv/system/engine/controller.php on line 47

    47:
    trigger_error('Error: Could not load controller ' . $child . '!');

    Как это исправить? Может есть другой работающий модуль?

    Opencart
    1.5.4

    СПАСИБО ЗА ОТВЕТЫ!
     
  2. Spartak

    Spartak

    Регистрация:
    23 дек 2012
    Сообщения:
    151
    Симпатии:
    57
    Добрый день
    Проверьте, как вариант, может быть у вас не все файлы модуля скопировались, так как, судя по ошибке, нет возможности подгрузить файл контроллера
     
  3. crystal_girl

    crystal_girl

    Регистрация:
    28 май 2013
    Сообщения:
    4
    Симпатии:
    0
    я перепроверила, все файлы скопированы и стоят в соответствующих папках.

    п.с. это может не в тему, но хотела поставить western union модуль, так тот не отображался в списке методов предоплаты.
    Как то странно, это уже второй модуль, с которым проблемы.

    Я просто вставляю файл в ту папку, каторая указана в скаченном зип файле. Например admin\view\template\module\side_banner.tpl
    Может нужно делать что-то еще?
     
  4. Serkist

    Serkist

    Регистрация:
    8 фев 2013
    Сообщения:
    350
    Симпатии:
    72
    нужно не только tpl файлы, вставлять, а все файлы из архива и именно по нужным папкам.
    + уверены, что модуль именно под вашу версию опенкарт?
     
  5. crystal_girl

    crystal_girl

    Регистрация:
    28 май 2013
    Сообщения:
    4
    Симпатии:
    0
    да, да вставлены все файлы из зип архива кроме рид ме. Я ради примера только указала этот файл.

    Compatibility v1.5.4, значит под мою...
     
  6. Serkist

    Serkist

    Регистрация:
    8 фев 2013
    Сообщения:
    350
    Симпатии:
    72
    попробуйте другой слайдер поставить, например nivoslader у меня замечательно работает на 1.5.4.1
     
  7. crystal_girl

    crystal_girl

    Регистрация:
    28 май 2013
    Сообщения:
    4
    Симпатии:
    0
    подскажите где вы этот модуль скачивали? :smile:

    МНЕ НУЖЕН ИМЕННО БОКОВОЙ как на картинке:

    [​IMG]
     
  8. Serkist

    Serkist

    Регистрация:
    8 фев 2013
    Сообщения:
    350
    Симпатии:
    72
    да честно говоря, не помню. Знаю только, что он бесплатный.
    Попробуйте поискать здесь, на форуме.
    По поводу бокового - утверждать не буду, что он подходит. У меня использовался на главной в середине.