[Решено] Настройка модуля Авторизации

Тема в разделе "Joomla", создана пользователем ulka5659, 7 май 2018.

Статус темы:
Закрыта.
  1. ulka5659

    ulka5659

    Регистрация:
    7 май 2018
    Сообщения:
    5
    Симпатии:
    0
    Здравствуйте. Есть сайт в котором необходимо пройти процедуру Авторизации. На джумла. Модуль подключен, настроен. Работает регистрация, письма приходят на почту для подтверждения регистрации. Проблема в том что в последствии, при входе пользователя на сайт вываливается:
    Страница недоступна
    Сайт sad08.kz пока не может обработать этот запрос.

    Не могу найти где осуществляется переход на сайт после нажатия кнопки. В настройках модуля всяко пробовала и по умолчанию, и конкретно указывать страницы сайта - не помогает. Возможно еще причина в том что я сайт переносила с бесплатного хостингиа. Возможно криво получилась. И при получении письма, в процессе регистрации, в теме сообщения возникает адрес старого сайта: Параметры учётной записи для Елена на сайте http://uvk.16mb.com а по идее должно быть http://Sad08.kz Может быть что где-то указан не тот адрес сайта и все из-за этого? Подскажите где можно посмотреть еще? Смотрела тут: .htaccess, index.php, template.css, configuration.php. Ничего не вижу...
     
  2. spy

    spy

    Регистрация:
    15 янв 2013
    Сообщения:
    464
    Симпатии:
    135
    В дампе базы, замените все старые адреса сайта на новый (через простой поиск/замена)
    И в админке еще раз проверте, что бы были везде указаные новый адрес сайта
    --- Добавлено, 7 май 2018 ---
    + у вас много ошибок на сайте, почистите кэш сайта и модулей
     
  3. ulka5659

    ulka5659

    Регистрация:
    7 май 2018
    Сообщения:
    5
    Симпатии:
    0
    Здравствуйте. Спасибо за помощь!!! Сделала как Вы сказали. В дампе БД были косяки, исправила. Нашла сервис который показывает ошибки сайта, исправила в .htaccess ошибку "Редирект со страниц index (.html и .php) настроен не правильно"
    добавила код
    RewriteEngine On
    RewriteCond %{THE_REQUEST} ^[A-Z]{3,9}\ /index\.html\ HTTP/
    RewriteRule ^index\.html$ http://sad08.kz/ [R=301,L]

    RewriteCond %{THE_REQUEST} ^[A-Z]{3,9}\ /index\.php\ HTTP/
    RewriteRule ^index\.php$ http://sad08.kz/ [R=301,L]

    Проверка то выдает, что настроено правильно, то нет....

    Авторизуюсь теперь странно, вроде ошибку не выдает, но и не видно зашел на сайт пользователь или нет. Если тут же завожу другого пользователя на сайт, он не грузится. В заголовке старый фавикон и пустая страница ни ошибок ничего.... Чищу кеш браузера, сайт загружается... Что происходит? А ошибки которые выдает проверка, могут влиять так сильно на работу авторизации? И почему я не вижу кнопки "выход" для смены пользователя, что еще надо настроить? В модулях и плагинах вроде нет таких настроек??
    Я первый сайт настраиваю, все самостоятельно, так что конечно многое для меня не понятно.
    Проверяюсь тут https://sitechecker.pro/ru/seo-report/http://sad08.kz
     
  4. spy

    spy

    Регистрация:
    15 янв 2013
    Сообщения:
    464
    Симпатии:
    135
    Вы с htaccess сильно накрутили
    такой адрес http://sad08.kz/index.php/vkhod неможет быть
    на главной ошибка в jQuery функции, дальше жс не работает
    и нет доступа к некоторым файлам или их нет вообще - все в консоли смотрите
     
  5. ulka5659

    ulka5659

    Регистрация:
    7 май 2018
    Сообщения:
    5
    Симпатии:
    0
  6. spy

    spy

    Регистрация:
    15 янв 2013
    Сообщения:
    464
    Симпатии:
    135
    Значит, накрутили с редиректами
    плагины могут неработать из-за жса
    поправте все жс ошибки
     
  7. Artmaker

    Artmaker

    Регистрация:
    30 янв 2015
    Сообщения:
    21
    Симпатии:
    0
    Также может проблема возникнут из-за sef компонента какой у вас работает встроеный или сторонний?
     
  8. ulka5659

    ulka5659

    Регистрация:
    7 май 2018
    Сообщения:
    5
    Симпатии:
    0

    Специально ничего не ставила, работает встроенный компонент. Почитала, сказано плагин SEF включить, вроде теперь грузится сайт, только кнопка "Выход" не появляется, и вывела модуль"Кто на сайте" имя пользователя не появляется ни в админке, ни на сайте... т.е авторизация перестала проходить теперь... Может я настройки не все знаю? Что еще посмотреть?
     
    Последнее редактирование: 22 май 2018
  9. ulka5659

    ulka5659

    Регистрация:
    7 май 2018
    Сообщения:
    5
    Симпатии:
    0
    Проблему решила. Ошибку давал плагин jvcounter. Нашла при помощи поиска php ошибок, в файле index.php прописав
    ini_set('error_reporting', E_ALL);
    ini_set('display_errors', 1);
    ini_set('display_startup_errors', 1);

    далее просто убрала папку с данным плагином, все. Спасибо за советы!!!
     
Статус темы:
Закрыта.