Фотографии миниатюр категорий

Тема в разделе "PrestaShop", создана пользователем Maimeri, 18 фев 2016.

  1. Maimeri

    Maimeri

    Регистрация:
    17 окт 2015
    Сообщения:
    44
    Симпатии:
    4
    Всем доброго времени суток.
    Возникла такая проблема на престе 1.6.1.2
    При создании Миниатюры категории на основном сайте остается картинка "нет фото".
    и ссылка на фото остается /c/ru-default-medium_default/ вместо /c/порядковый номер категории-medium_default/

    Хотя фотография на сервер сайта заливается и она там есть. Впечатление как будто сбились ссылки на изображения.

    При заливке фото в "Изображение обложки категории" созадает на основном сайте и обложку категории и миниатюру категории.

    Кто может подсказать решении проблемы или хотя бы причину.
     
  2. nabiyllin

    nabiyllin

    Регистрация:
    30 ноя 2014
    Сообщения:
    9
    Симпатии:
    0
    Apache используете?
    смотрите htaccess
     
  3. duke1999

    duke1999

    Регистрация:
    30 дек 2014
    Сообщения:
    164
    Симпатии:
    50
    выключите сохраните / включите сохраните в закладке Seo ЧПУ, чтобы .htaccess перегенерировать
     
  4. AndreyBN

    AndreyBN

    Регистрация:
    15 дек 2015
    Сообщения:
    3
    Симпатии:
    0
    у меня была аналогичная проблема
    решал след. способом
    заливал по фтп на сервер картинку категории id_категории.jpg по пути /img/c/
    дальше Настройки - Изображения - Пересоздать миниатюры и генерировал миниатюры для категорий
     
  5. GenerationP

    GenerationP

    Регистрация:
    24 янв 2016
    Сообщения:
    20
    Симпатии:
    9
    Встречал такую проблему.
    1) Стоить перепроверить правила перезаписи ссылок (Если стоит модуль типа AdvancedURL)
    2) Перепроверить правильность шаблонов tpl - те ли переменные у вас в пути
    3) возникала проблема при включении https, проверьте с ним или без
    4) Возможно Проблемы кеширования стоит почистить кеши на фтп в соответствующей папке.
    5) Кеширование на стороне хостинга, мемкеши, опкеши, кеширование картинок
    6) Включено ли кеширование в самом клиенте, и включить перекомпиляцию.
    7) Попробывать перерегенерировать миниатюры в настройках изображений.

    Попробуйте, может поможет)