Как сделать, чтобы сайт открылся по адресу http://www.site.ru

Тема в разделе "Мегафлуд", создана пользователем AlexaS, 26 ноя 2015.

  1. AlexaS

    AlexaS

    Регистрация:
    21 май 2015
    Сообщения:
    1
    Симпатии:
    0
    Очень нужно, чтобы при написании в адресной строке http://www.site.ru/ , сайт и открылся по адресу http://www.site.ru/ , а при написании http://site.ru/ - открылся по адресу http://site.ru/ .
    В WP же ВСЕГДА открывается http://site.ru/

    "Redirect 301" проблему не решает.......

    Как сделать?
     
  2. WC.Allex

    WC.Allex

    Регистрация:
    12 авг 2012
    Сообщения:
    0
    Симпатии:
    0
    укажите везде ссылки в админке и в бд все ссылки замените с site.ru на www.site.ru
    может Вы не так прописали 301?
    <IfModule mod_rewrite.c>
    Options +FollowSymLinks
    RewriteEngine on
    RewriteCond %{HTTP_HOST} ^www\.site\.ru$ [NC]
    RewriteRule ^(.*)$ http://site.ru/$1 [R=301,L]
    </IfModule>
     
  3. Белая Сова

    Белая Сова

    Регистрация:
    20 окт 2015
    Сообщения:
    1
    Симпатии:
    0
    Обратитесь в службу поддержки хостинга. У нас в свое время была проблема, когда редирект настроили, но он не работал. Оказалось, что с настройкой корпоративной почты намудрили и лишние действия сделали, которые повлияли на редирект. Сами об этом, конечно же, не узнали. Поддержка помогла.
     
  4. VaLeXaR

    VaLeXaR

    Регистрация:
    24 мар 2015
    Сообщения:
    61
    Симпатии:
    84
    Может это поможет?
     
  5. snoop

    snoop

    Регистрация:
    1 дек 2015
    Сообщения:
    5
    Симпатии:
    0
    Помогло?
     
  6. alexxx123

    alexxx123

    Регистрация:
    11 дек 2015
    Сообщения:
    0
    Симпатии:
    0
    А вообще зря это.. По сути дубли плодите..