[Решено] Кодировка

Тема в разделе "Wordpress", создана пользователем Savok32, 5 ноя 2014.

Статус темы:
Закрыта.
  1. Savok32

    Savok32

    Регистрация:
    18 дек 2012
    Сообщения:
    331
    Симпатии:
    51
    Уважаемые добрый день, проблема такая, когда обрезается текст, он ставит символы �.
    Как решить этот косяк.....

    http://goo.gl/3HkaTM
     
  2. web2us

    web2us

    Регистрация:
    10 мар 2013
    Сообщения:
    0
    Симпатии:
    0
    текст в кодировки utf8 а обрезается методами для win кодировки и в итоге не дорезает и получаются неизвестные символы в виде знака вопроса
    --- Добавлено, 5 ноя 2014 ---
    используй mb_ строковые функции
     
  3. Savok32

    Savok32

    Регистрация:
    18 дек 2012
    Сообщения:
    331
    Симпатии:
    51
    Код:
    <div id="system" class="service">
           
            <article class="item" data-permalink="<?php the_permalink(); ?>">
           
                <header>
           
                    <h1 class="title"><?php the_title(); ?></h1>
    
                </header>
    
    
    <div class="home-service">
                <div class="nspArts bottom" style="width: 100%">
                <div class="nspArtPage">
        <?php $paged = (get_query_var('paged')) ? get_query_var('paged') : 1;
             query_posts("post_type=service&showposts=12&paged= $paged"); ?>
        <?php while(have_posts()) : the_post(); ?>
       
        <div class="nspArt nspCol5" style="padding:0 10px 0px 10px;">
              <div class="nspArtWrapper">
                <h4 class="nspHeader tcenter fnone"><a href="<?php the_permalink() ?>" title="<?php echo get_the_title(); ?>"><?php echo get_the_title(); ?></a></h4>
                <!-- Begin Thumb Container -->
                <div class="center tcenter fleft gkResponsive">
                <a href="<?php the_permalink() ?>" class="nspImageWrapper tcenter fleft gkResponsive" style="margin:6px 7px 15px 7px;"><img class="nspImage" src="<?php echo get_template_directory_uri(); ?>/timthumb.php?src=<?php echo catch_that_image() ?>&amp;w=156&amp;h=156" alt="<?php the_title(); ?>" /></a></div>
                <!-- End Thumb Container -->
                <p class="nspText tcenter fleft"><?php echo mb_substr(get_the_excerpt(), 0,170); ?></p>
              </div>
            </div>
       
       
       
        <?php endwhile; ?>
       
    
      </div>
            </div>
            </div>
    
    <span class="hr"></span>
    
    </article>
    
           
    
    </div>
    
    заменил как бы на, но всё равно не пашет
    <p class="nspText tcenter fleft"><?php echo mb_substr(get_the_excerpt(), 0,170); ?></p>
     
  4. web2us

    web2us

    Регистрация:
    10 мар 2013
    Сообщения:
    0
    Симпатии:
    0
    а это что? и что выдает
     
  5. Bnopen

    Bnopen Команда форума

    Регистрация:
    3 мар 2013
    Сообщения:
    1.155
    Симпатии:
    514
    Savok32, поменяй на utf8_substr.
    Вот здесь похожая тема в разделе ОС -
     
  6. Savok32

    Savok32

    Регистрация:
    18 дек 2012
    Сообщения:
    331
    Симпатии:
    51
    я хз, что это.....
     
  7. Bnopen

    Bnopen Команда форума

    Регистрация:
    3 мар 2013
    Сообщения:
    1.155
    Симпатии:
    514
  8. Savok32

    Savok32

    Регистрация:
    18 дек 2012
    Сообщения:
    331
    Симпатии:
    51
    с utf8_substr тоже не работает
    --- Добавлено, 5 ноя 2014 ---
    всё решил помогло mb_substr,
    косяк был в том что, надо менять не через админку.....а в шаблоне в папки виджет.....
     
Статус темы:
Закрыта.