(Опрос) Поддержку какой версии IE вы считаете обязательной?

Тема в разделе "Вёрстка (HTML, CSS)", создана пользователем IvanCo, 18 янв 2013.

?

Поддержку каких версий IE вы считаете обязательной на данный момент?

  1. 6 и более новых

    3 голосов
    3,2%
  2. 7 и более новых

    18 голосов
    18,9%
  3. 8 и более новых

    37 голосов
    38,9%
  4. 9 и новее

    37 голосов
    38,9%
  1. alex_storm

    alex_storm дизайн, CSS Команда форума

    Регистрация:
    11 дек 2012
    Сообщения:
    1.121
    Симпатии:
    560
    От 8 апреля 2014 microsoft перестает поддерживать IE-8 (Радуемся и закрываем его) Пусть идут все обновляться.
     
  2. LuisAlberto

    LuisAlberto

    Регистрация:
    1 июл 2014
    Сообщения:
    14
    Симпатии:
    2
    То, что они его перестают поддерживать ещё не означает, что его перестанут использовать. Вон, WinXP уже столько времени не поддерживают, а если посмотреть статистику — то количество использующих её преизряднейшее до сих пор.
     
  3. zaibatsuhmao

    zaibatsuhmao

    Регистрация:
    16 окт 2014
    Сообщения:
    2
    Симпатии:
    2
    IE это как наказание для разработчиков, если бы госсайты не затачивали под него, он бы вообще был невостребованным.
     
  4. Blofield

    Blofield

    Регистрация:
    15 апр 2013
    Сообщения:
    17
    Симпатии:
    2
    Xp тоже перестали поддерживать, но количество пользователь пока очень большое. Я считаю, что поддержка должна быть с 8 и выше.
     
  5. vladalien

    vladalien

    Регистрация:
    21 окт 2014
    Сообщения:
    9
    Симпатии:
    2
    На всех серьёзных проектах, где доводилось работать, мы поддерживали 8 и выше. Хотя лично моё мнение, я бы и 8 не поддерживал, ибо геморно просто ппц как. Но, заказчику виднее, так как это в основном крупные компании, то я уверен, что они делали исследования и вполне аргументированно выдвигали такое требование. За сей пункт и проголосовал.
     
  6. soslow

    soslow

    Регистрация:
    1 ноя 2014
    Сообщения:
    2
    Симпатии:
    0
    Вот статистика от liveinternet.ru. Доля 7-8-9 эксплореров в сумме 2.3%. Ну и какой смысл заморачиваться их поддержкой?
     
  7. kir-lys

    kir-lys

    Регистрация:
    18 ноя 2014
    Сообщения:
    12
    Симпатии:
    0
    Думаю с 8 версии, и скрипт на сайте для тех кто заходит с версий ниже, типа того как, обновите браузер... или сайт корректно отображается там то, там то
     
  8. Vivec

    Vivec

    Регистрация:
    24 ноя 2014
    Сообщения:
    105
    Симпатии:
    15
    Мой аргумент, основанный на опыте одного сайта.
    Интернет магазин товаров для женщин и мужчин (одежда, белье). Посещаемость 200-400 человек в день (Украина и Россия).

    Данные за ноябрь:
    Google Chrome - 28,8%
    Opera - 20,9%
    Firefox - 18,8%

    IE - 4,7%
    IE 11.0 - 2,3%
    IE 10.0 - 0,8%
    IE 9.0 - 0,9%
    IE 8.0 - 0,7%
    IE 7.0 - 0,1%
    IE 6.0 - 0

    Вот чего ради стоит учитывать посетителей ниже 9.0, которые заходят с "робика" на сайт? Вероятность того, что такие посетители что-то купят ничтожно мала.
     
  9. lDeusExMachina

    lDeusExMachina

    Регистрация:
    18 янв 2015
    Сообщения:
    11
    Симпатии:
    0
    Считаю что IE начиная с 10 версии вполне адекватен, все что было раньше - в треш. Если перестать этот треш поддерживать - глядишь все пересядут на нормальные браузеры и геммороя станет меньше. Люблю лепить заплатки аля "сайт не поддерживается вашим унылым ишаком"
     
  10. m0z

    m0z

    Регистрация:
    23 янв 2015
    Сообщения:
    1
    Симпатии:
    0
    Думаю с 9 версии, сайт корректно отображается. а дальше проблемы
     
  11. Копост

    Копост

    Регистрация:
    24 янв 2015
    Сообщения:
    35
    Симпатии:
    0
    Да практически все уже перешли на webkit, firefox от ие уговариваю отказаться всех своих клиентов
     
  12. Gevano

    Gevano

    Регистрация:
    11 янв 2015
    Сообщения:
    34
    Симпатии:
    5
    В youtube уже все на HTML5 и когда ты заходишь туда со старого осла, например с 8-9 то тебе говорят, что все плохо, пора обновится. Этот фактор говорит о том, что все больше людей сталкивая с проблемой старых версий ослов сами не состоянии обновить браузер до версий 10-11... и скачивают альтернативу. Поэтому процент старых ослов мал и продолжает уменьшаться так как пипл хочет развлекаться. Поэтому поддержка с 9 версии.
     
  13. Dotrox

    Dotrox Команда форума

    Регистрация:
    27 ноя 2012
    Сообщения:
    2.051
    Симпатии:
    779
    Это связано с политикой Гугла по поддержке только двух последних версий каждого браузера. Через пару месяцев выйдет ИЕ12 (правда, не факт, чт он будет так называться) и все сервисы Гугла начнут выдавать такое сообщение и пользователям ИЕ10.
    Ориентироваться нужно на процентное соотношение браузеров в регионе (например, ИЕ на Западе намного популярней, чем у нас, зато Оперой там почти никто не пользуется) и на соотношение браузеров у пользователей сайта, если сайт уже работает и имеет достаточно посетителей для объективности такой статистики.
    Если сайт ориентирован на СНГ, можно спокойно отказываться от версий ИЕ ниже 10 (здесь общий процент ИЕ всех версий не превышает 20%, из них минимум 2/3 - это ИЕ10 и ИЕ11), но для других регионов может понадобиться поддержка даже ИЕ8.
     
    Gevano нравится это.
  14. Gevano

    Gevano

    Регистрация:
    11 янв 2015
    Сообщения:
    34
    Симпатии:
    5
    Опера это тот же Google Chrome. Что касается "запада" то недавно делал сайт для США и заказчик в ТЗ указал поддержку браузеров IE 9 и выше. Вообще я считаю, для молодых сайтов лучше всего настроить определение версии IE и в случае версий ниже 10 выдавать предупреждение. Очень экономит время чтобы не писать "костыли". Ну и естественно для не молодых сайтов - только статистика.
     
  15. Dotrox

    Dotrox Команда форума

    Регистрация:
    27 ноя 2012
    Сообщения:
    2.051
    Симпатии:
    779
    Вот только из-за того, что 12 сама не обновляется на Блинк, у многих сейчас ещё стоит старая Опера. А некоторые принципиально не переходят на новую.