Проблема при установке шаблона

Тема в разделе "OpenCart", создана пользователем mars00, 29 июн 2014.

Статус темы:
Закрыта.
  1. mars00

    mars00

    Регистрация:
    30 май 2014
    Сообщения:
    5
    Симпатии:
    0
    Уведомление : Неопределенная переменная: content_header_block в / home/m/mars00/ecotrava.ru/public_html/catalog/view/theme/OPC040084/template/common/header.tpl на линии 98



    Установил шаблон от TemplateMela, а при установке у меня вот такая ошибка появляется. В поддержке TemplateMela я ответ не получил. Кто знает подскажите что поправить надо на линии 98?
     
  2. zvizdunov

    zvizdunov

    Регистрация:
    31 май 2014
    Сообщения:
    105
    Симпатии:
    33
    А что находится в 98 строке?
     
  3. mars00

    mars00

    Регистрация:
    30 май 2014
    Сообщения:
    5
    Симпатии:
    0
    <?php echo $content_header_block; ?>
    строчка вот такая)
     
  4. mars00

    mars00

    Регистрация:
    30 май 2014
    Сообщения:
    5
    Симпатии:
    0
    Тех поддержка помогла, проблему решил)
     
  5. glad

    glad

    Регистрация:
    7 ноя 2014
    Сообщения:
    15
    Симпатии:
    0
    У меня такая же проблема после установки шаблона. Подскажите пожалуйста как ее решить?
    Notice: Undefined variable: content_header_block in Z:\home\shop.ru\www\catalog\view\theme\OPC040084\template\common\header.tpl on line 98
     
  6. chukcha

    chukcha

    Регистрация:
    9 окт 2014
    Сообщения:
    281
    Симпатии:
    85
    Переменная должна быть сформирована в контроллере, header.php

    Если тема поставляется с vqmod, то нужно посмотреть в код xml темы.
     
  7. Lima

    Lima

    Регистрация:
    24 авг 2013
    Сообщения:
    9
    Симпатии:
    0
    Вопрос на мой вгляд в первую очередь должен звучать так, на какую версю опенкарт статвити. Совместими ли версии. Используется ли в Вашем случае как либо сборка, например максисторе , чем выше версия максисторе чем больше кодов переделано а это значит, что шаблоны подойдут только для максисторе. и такое может быть с подобными сборками. используйте осторе или максисторе версии не позднее 1541 или голый опенкарт
     
  8. glad

    glad

    Регистрация:
    7 ноя 2014
    Сообщения:
    15
    Симпатии:
    0
    У меня версия Opencart 1.5.6.4 , шаблон Opencart Files_1.5.6.x . Интересно, что у многих выскакивает данная ошибка при установке этого шаблона.
     
Статус темы:
Закрыта.