[Помогите] Проблема с подключением css

Тема в разделе "Wordpress", создана пользователем fanton123, 28 сен 2015.

  1. fanton123

    fanton123

    Регистрация:
    24 дек 2012
    Сообщения:
    256
    Симпатии:
    29
    Есть: WordPress 4.3.1, тема The7, модуль autoptimize(собирает, оптимизирует и переносит в подвал CSS и JS), модуль Google Pagespeed Insights.
    Суть проблемы: все настроил и оптимизировал проверяю:
    1. Проверяю главную страницу на скорость Google Pagespeed. Выдает результат 88 и простит сократить время ответа сервера.
    2. Проверяю другую страницу пишет "Удалите из верхней части страницы код JavaScript и CSS, блокирующий отображение", но если посмотреть в код этот файл расположен внизу страницы.

    Не могу понять в чем проблема, почему google решил что этот файл в шапке, помогите.

    Пациент.

    Результаты могут меняться, занимаюсь разработкой данного сайта.
     
  2. Bnopen

    Bnopen Команда форума

    Регистрация:
    3 мар 2013
    Сообщения:
    1.155
    Симпатии:
    514
    Какую страницу? Дайте линк.
     
  3. fanton123

    fanton123

    Регистрация:
    24 дек 2012
    Сообщения:
    256
    Симпатии:
    29
    к примеру эта http://phoenixgold.aac.in.ua/o-nas/

    Google упорно говорит что в шапке есть файл
    "http://phoenixgold.aac.in.ua/wp-con...optimize_3250220cdcde6236ab69ab74ab374b52.css"
    который подключен в <head> хотя он внизу в <body>

    https://developers.google.com/speed...tp://phoenixgold.aac.in.ua/o-nas/&tab=desktop
     
    Последнее редактирование: 28 сен 2015
  4. Bnopen

    Bnopen Команда форума

    Регистрация:
    3 мар 2013
    Сообщения:
    1.155
    Симпатии:
    514
    fanton123, если смотреть в коде, то стиль в подвале сайта, странно что бот его видит в шапке.
    В коде смутило только вот это в шапке -
    <style type="text/css" id="static-stylesheet"></style>

    Ну а такое странное перемещение может делает модуль pagspeed, там же есть что-то вроде этого -