[Помогите] Проблема с cURL при установке Opencart

Тема в разделе "OpenCart", создана пользователем alex_storm, 28 дек 2012.

  1. alex_storm

    alex_storm дизайн, CSS Команда форума

    Регистрация:
    11 дек 2012
    Сообщения:
    1.120
    Симпатии:
    560
    Интересная ситуация получилась) Никогда не выскакивала данная ошибка, а теперь не могу от нее избавиться:
    Warning: CURL extension needs to be loaded for OpenCart to work!

    Может кто то сталкивался с подобным??
     
  2. Baco

    Baco Антихронофаг Команда форума

    Регистрация:
    9 окт 2012
    Сообщения:
    648
    Симпатии:
    327
  3. alex_storm

    alex_storm дизайн, CSS Команда форума

    Регистрация:
    11 дек 2012
    Сообщения:
    1.120
    Симпатии:
    560
    Прикольно... Я тут ничего понять не могу..( Что значит: "Для использования cURL необходимо собрать PHP с опцией --with-curl[=DIR]"?
    Подскажите, а можете как то в крациях объяснить как его ставить, а то тут что то очень страшное написано.. Я еще смотрел тут http://forum.opencart.com/viewtopic.php?f=19&t=5970#p28548 Но чтобы все работало, нужен xamp, а я привык уже к денверу.. (
     
  4. Baco

    Baco Антихронофаг Команда форума

    Регистрация:
    9 окт 2012
    Сообщения:
    648
    Симпатии:
    327
    переключите в денвере версию ПХП 5.3
     
    Domovikx нравится это.
  5. alex_storm

    alex_storm дизайн, CSS Команда форума

    Регистрация:
    11 дек 2012
    Сообщения:
    1.120
    Симпатии:
    560
    У меня стоит версия PHP/5.3.3
     
  6. Baco

    Baco Антихронофаг Команда форума

    Регистрация:
    9 окт 2012
    Сообщения:
    648
    Симпатии:
    327
    http://www.denwer.ru/packages/php5.html
    --- добавлено: 28 дек 2012 в 19:42 ---
    После установки пакета (скачанного) открываеш usr/local/php5/php.ini и снимаеш коммент со строчки:

    Код:
    ;extension=php_curl.dll
     
  7. alex_storm

    alex_storm дизайн, CSS Команда форума

    Регистрация:
    11 дек 2012
    Сообщения:
    1.120
    Симпатии:
    560
    Нашел, но не работает ((( Странно как то это все..
     
  8. Baco

    Baco Антихронофаг Команда форума

    Регистрация:
    9 окт 2012
    Сообщения:
    648
    Симпатии:
    327
    перезагрузи денвер.
     
  9. alex_storm

    alex_storm дизайн, CSS Команда форума

    Регистрация:
    11 дек 2012
    Сообщения:
    1.120
    Симпатии:
    560
    Да пробовал уже раз 5... Че то он вообще глючит... Может комп полностью перегрузить?? Сейчас попробую отпишу..
     
  10. Baco

    Baco Антихронофаг Команда форума

    Регистрация:
    9 окт 2012
    Сообщения:
    648
    Симпатии:
    327
    Перешел на OpenServer и не жалею...
     
  11. alex_storm

    alex_storm дизайн, CSS Команда форума

    Регистрация:
    11 дек 2012
    Сообщения:
    1.120
    Симпатии:
    560
    Наверное так и сделаю... Проблема не решилась ((
     
  12. VivaLaMax

    VivaLaMax

    Регистрация:
    30 дек 2012
    Сообщения:
    46
    Симпатии:
    4
    Попробуйте зайти с другого браузера. Если не поможет попробуйте еще раз заново проделать манипуляцию с файлом php.ini после чего перезагрузите сервер.
    В файле нужно изменить
    Код:
    ;extension=php_curl.dll
    на
    extension=php_curl.dll
     
  13. alex_storm

    alex_storm дизайн, CSS Команда форума

    Регистрация:
    11 дек 2012
    Сообщения:
    1.120
    Симпатии:
    560
    Выше написано =)) Уже меняли.. Проблема решилась переходом на OpenServer
     
    Baco нравится это.
  14. Grek

    Grek

    Регистрация:
    18 янв 2013
    Сообщения:
    172
    Симпатии:
    18
    Та же печаль на версиях 1.5.6 и 2.0. Сам ставил php, mysql, apache. Curl включил (extension=php_curl.dll), сервер перегружал, однако ошибка с курлом не пропала.