[Помогите] 1.5.5.1 vs 1.5.4.1

Тема в разделе "OpenCart", создана пользователем Serkist, 14 май 2013.

  1. Serkist

    Serkist

    Регистрация:
    8 фев 2013
    Сообщения:
    350
    Симпатии:
    72
    Какие принципиальные отличия первой версии от второй, стоит ли переходить на нее, если стоит ОК 1.5.4.1?
     
  2. sitecreator

    sitecreator

    Регистрация:
    1 фев 2013
    Сообщения:
    291
    Симпатии:
    65
    Вы со СВОИМИ задачами сначала определить, а потом уже можно решать о переходе.
    Например, для новой версии может и не быть нужного вам модуля, а для старой он есть.
     
  3. Vlad-i-Slav

    Vlad-i-Slav

    Регистрация:
    20 мар 2013
    Сообщения:
    251
    Симпатии:
    159
    Согласен с sitecreator, но дело не в задачах. Главная проблема - модули и шаблоны. Устанавливал 2 платных модуля, оба работают криво
     
  4. stifutkin

    stifutkin

    Регистрация:
    22 дек 2012
    Сообщения:
    172
    Симпатии:
    43
    История изменений с официального сайта
     
    Yuriy_Z нравится это.
  5. dobson

    dobson

    Регистрация:
    19 апр 2013
    Сообщения:
    5
    Симпатии:
    0
    В версии 1.5.5 одно из нововведений встроенный фильтр товаров. Раньше его нужно было ставить как модуль. Он довольно простой, фильтрует по, специально для этого создаваемых, фильтрах. А не так как остальные модули фильтров по атрибутам с опциями.
     
  6. noobie

    noobie

    Регистрация:
    27 мар 2013
    Сообщения:
    173
    Симпатии:
    22
    Переходить не стоит. Много модов и шаблонов заточены под более старые версии. Из плюсов там только фильтры которые можно реализовать модами в 1.5.4.1
     
  7. Bnopen

    Bnopen Команда форума

    Регистрация:
    3 мар 2013
    Сообщения:
    1.155
    Симпатии:
    514
    Как пишет сам Daniel адаптация старых модулей под ос 1.5.5.1 - не очень сложное дело -
     
  8. sitecreator

    sitecreator

    Регистрация:
    1 фев 2013
    Сообщения:
    291
    Симпатии:
    65
    а зачем нам эта адаптация? потренироваться? ведь на это нужно время потратить и не факт, что удачно получится, когда есть уже проверенные временем модули на все случаи жизни для 1.5.4.1. и то не все.
    Мне, например, с лихвой хватает адаптации некоторых буржуйских модулей под ocStore.
     
  9. galas

    galas

    Регистрация:
    6 фев 2013
    Сообщения:
    105
    Симпатии:
    3
    если всё работает, полный набор нужных модулей - какой смысл переходить?
    по-крайней мере сейчас. Подождать до осени - как все осн. модули под нов. версию доработают и новые выпустят.
    А то, глядишь, и ещё, следующая версия к тому времени появится - тогда 1.5.5.1 смело можно будет пропустить вообще.
     
  10. sitecreator

    sitecreator

    Регистрация:
    1 фев 2013
    Сообщения:
    291
    Симпатии:
    65
    по крайней мере стоит дождаться выхода 1.5.5.1 ocStore если вы работаете на русскоязычную публику.
     
  11. galas

    galas

    Регистрация:
    6 фев 2013
    Сообщения:
    105
    Симпатии:
    3
    именно так.
    Я сам сейчас жду выхода 1.5.5.1 ocStore - готовлю 2 новых сайта, пока в стол, контент и модули в сборку подбираю.
    А прежние сайты спокойно на 1.5.4.1 работают. И, видимо, обновлять тоже, и потом не буду - смысл?
     
  12. Styler247

    Styler247

    Регистрация:
    16 май 2013
    Сообщения:
    87
    Симпатии:
    2
    Следующая версия вероятно приходит рано, так что его, вероятно, лучше пропустить 1.5.5.1 на данный момент ..
     
  13. marand

    marand

    Регистрация:
    12 фев 2013
    Сообщения:
    32
    Симпатии:
    0
    Не подскажете когда планируется выпуск? А то тоже готов к запуску проекта, подобран шаблон на 1.5.5.1 и хотелось бы сделать на свежей версии.
     
  14. SpideR

    SpideR

    Регистрация:
    24 окт 2012
    Сообщения:
    29
    Симпатии:
    4
    Глобальных изменений в 1.5.5.1 нет. Так что не думаю что вам стоит переходить на ее.
    Если проект разрабатывается с нуля, тогда да, а обновлением лишь багов себе добавите.